Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > YJ leaking oil, not burning????

Join Wrangler Forum Today


Thread: YJ leaking oil, not burning???? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-24-2011 05:42 PM
kik That is alot of oil to be going through. On my stock 89 4.2 there is a breather at the rear of the valve cover that vents into the air cleaner through the "breather element". There is also the PCV at the front of the valve cover. Check both and replace the PCV, assuming you have a stock set up. I've only heard of using that much oil if you have bad rings, which you would be burning it. I really don't see that much oil pushing out of the "vents". Behind the oil filler cap you should have a PCV in place and no smoke should be coming out of it. I think you have a few problems contibuting to this condition. I do think that you're burning oil also.
04-24-2011 02:46 PM
rambo3489
YJ leaking oil, not burning????

I have a 89 YJ with the 4.2L. Its using oil, around a quart every 300 Miles. Its not burning it, its not leaking. Theses no puddle on the driveway, the pressure sending unit seems to be holding oil. The only thing I can think of is the round vent like thing on the top of the valve cover behind the fill cap puffs out a little smoke. Almost like a little train engine. Is that supposed to happen? That's the only possible cause of it using oil that I can see. Any ideas on why its using the oil? I read that a lot of times it is the pressure sending unit leaking, or a blocked breather tube. Is there a breather tube on the 4.2L? I looked real quick on the engine but didn't see anything. But if that is clogged that would maybe cause the oil to vaporize out of the vent on top, maybe? Ideas would be helpful.

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:48 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC