Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > 2006 wrangler unlimited automatic trans slips

Join Wrangler Forum Today


Thread: 2006 wrangler unlimited automatic trans slips Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-26-2012 01:20 PM
jeeptex
2006 Wrangler unlimited tranny slip

Auto transmission, slips at first then clears up eventually, until it sits for a while, having to start in first manually shift to second then drive, works fine that way, tells me that maybe the transmission plates are fine( sorta) but it needs more temperature inside the transmission to engage them.

Have any of you solved the problem? Still working fine despite the need to warm up?

Thanks
04-21-2012 12:41 AM
nissanman1 i've got an 03 that slips when the engine is cold and you move it for the first time. after it warms up not a prob. we may have the same issue but darned if i know what it is. good luck. i've heard if you park on an incline that will affect it or if the fluid is the least bit low. that is all i've heard so far.
04-11-2012 12:15 PM
Shrimpbush
???

Did you ever work this out? I'm dealing with the same problem right now on an 06 TJL.
04-25-2011 03:51 PM
Navic 2500 and 1600
04-25-2011 10:49 AM
Navic Thanks JD, I live in Florida 80's. From a cold start 1st goes up to 25000 RPM before 2nd kicks in. When I reach 210 engine temp the problem goes away and it shifts around 16000 RPM.
04-24-2011 05:38 PM
JDsDream Welcome to the Forum

I'm not sure where you are located, but is it still cold there and are you letting the Jeep warm up first? How high are the rpms going before it will shift?
04-24-2011 02:52 PM
Navic
2006 wrangler unlimited automatic trans slips

My 2006 wrangler unlimited automatic transmission just started to slip or stick in 1st gear then finally goes into 2nd. After driving down the road for awhile it clears up. The fluid is a nice red color and no leaks are seen. What should I check next????

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:40 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC