Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > Spark Plugs

Join Wrangler Forum Today


Thread: Spark Plugs Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-06-2011 08:23 PM
relemcke
Spark Plugs

Changed the plugs today, Champion RC12ECC(same that came out) gap to 0.035 torqued to 26ft-lbs. Took out the rail bolts letting it hang, changed the plugs, dielectric grease install rail snugged bolts evenly, torqued to 250 in-lbs, reinstall the air tube. When I started it it ran crazy with all the lights flashing on the dash. Tried again same thing. I did not disconnect the battery when I took off the Ignition rail. Disc. the battery now it runs and stalls. Took out the plugs and rechecked them put back and starts then stalls. PLEASE HELP.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC