Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Jeep hesitation/missing

Join Wrangler Forum Today


Thread: Jeep hesitation/missing Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-30-2011 04:02 AM
BrooksWV PS: I feel this was all caused because of that down shift to slow down on that hill. Never had any problems out of it before this. 2003 sport, 120k miles. All fluilds and plugs changed at 100k... Ran great until today. Starts fine now just misses non stop while running. Pretty sure it's making a metel on metel noise. Could just be because it's missing. Don't know if something is broke in there? I know all the little things to change to fix this... Plugs, coil pack, ect. Looking for worst case here? Engine rebuild or what? What is the most expensive thing that it REALLY might be? I'm not even close to rich and need my daily drive. No backup.
05-30-2011 03:57 AM
BrooksWV
Jeep hesitation/missing

I was driving in town today. Coming down a steep hill maybe 10/15 MPH shifted to 2nd to help slow it down before the bottom. Normal driving condition. Jeep died. Only noticed because steering stopped working. Went to start it and it all most would not start. Started missing on start and making lots of bad sounds (metel clicking/breaking sounds). Those only lasted 10/15 sec. Couldn't pull over so continued to drive. Still missing but running better. Got it home, almost seemed like it stopped missing. Drove to advance because Check engine light was on and was missing here and there. Test said engine cylinder miss fire (Well No $hit) on the way home light was flashing and jeep was missing really bad. I kind of know my away around Jeeps and this feels like a bad, bad thing? Any clues what it might be?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC