Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > New install today and i broke something!!

Join Wrangler Forum Today


Thread: New install today and i broke something!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-26-2011 03:35 PM
That99SaharaGuy Like you said, at least your stereo sounds awesome

Pictures asap!
06-26-2011 03:31 PM
Kevinm2467
New install today and i broke something!!

Today I was bored, my son, daughter and my girl was gone all day and I said this is a perfect time to play with my jeep! :-) I wanted to do something that won't cost money and make a huge improvement! I remembered I had a phoniex gold amp 800 watts and 4 channels. So that was my mission. I already had infinity speakers in the sound bar and in the dash and I have a huge amount of wires because I'm a car audio freak. Well I wired up the amp and all my speakers and said I will just use the bolt that holds down the rear seat as my grounding point. Well it sheared off and now I can't put my rear seat back in. But my stereo sounds awesome!!! Lol :-))). I guess I have another project with a easy out to get the bolt out :-( I didn't even need that location to ground the amp! Face palm.... Well I will have more pic after my 6x9 boxes come in. I did a clean install for the most part since I have no carpet and my baby is rhino-lined on the inside :-)))))

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:22 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC