Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > 2006 Jeep Wrangler transmission Problem

Join Wrangler Forum Today


Thread: 2006 Jeep Wrangler transmission Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-12-2011 09:52 AM
kfdjason7620 Definetly definetly need to get the fluid and filter changed and putting in an aftermarket transmission cooler will not hurt it, overheated tranny fluid GREATLY decreases it life and tranny life, just hope its not too late, and alot of people say any atf+4 will work, id get a quality synthetic fluid to put in it, but rule of thumb is if there's more than a teaspoon of metal in the pan then its time for a rebuild(or I think its teaspoon, maybe tablespoon)
07-12-2011 09:37 AM
ghawkins33
2006 Jeep Wrangler transmission Problem

I have a 2006 Right Hand Drive Jeep Wrangler. I am a rural Letter Carrier. I drive this Jeep daily 53 miles with 546 stops. After I have driven it for a couple of hours the transmission has a hard shift into the high gear. It also puts off excessive heat. If you touch the bumper or the hood you can not, it will burn you. I have replaced the radiator 3 times the heater core 3 times and gone thru 2 batteries. Replaced the universal joints. It has 68,000 miles on it. I have had nothing but trouble. Can anyone help me in diagnosing this problem?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC