Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > light problems

Join Wrangler Forum Today


Thread: light problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-17-2011 09:52 PM
tantryan Fixed it, the headlight problem was just a lose ground that i stumbled upon when adding new kc's.

Thanks everyone!
07-31-2011 11:11 PM
Buddy B Sure does sound like you got alot going on with/in your steering column, if not bulbs you might be looking at replacing the multi function switch, very common...
07-31-2011 11:04 PM
Shelby427 Look for bad grounds, it sounds like you have a couple, and the systems are back feeding on the others to work.

As stated the right TS sounds like a bad bulb.
07-31-2011 09:32 AM
paredline Somebody has been messing with your wiring. I would take a relay and use the lead from the headlight switch to power the headlights separately. Then everything will work.

The turn signal blinks rapidly because you have a blown bulb.
07-30-2011 11:05 PM
tantryan
light problems

So I have been having some problems lately with my headlights and turn signals. When I turn on the headlights the left one dims and also the horn doesnt work. Secondly when the headlights are on and i use my turn signal to the left the signal light and left headlight blink rapidly. Also when the headlights are on the left turn signal light on the dash board remains lit. When the headlights are not on the horn works perfect and so does the left turn signal. However when the headlights are not on the right turn signal blinks rapidly.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:53 PM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC