Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Oil pressure sending location? 4.2L

Join Wrangler Forum Today


Thread: Oil pressure sending location? 4.2L Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-31-2011 12:57 PM
5double0 Ok. I unhooked an re attached that and still pegged. However, My wire looks to be centered on the terminal and yours looks offset, so perhaps I'm not actually making contact. I will redo it and advise. Thanks for the pic!
07-29-2011 05:47 PM
scott howard sorry i was thinking temp sensor for some reason..lol
07-29-2011 05:56 AM
StinkyMud Here ya go.. This is taken just after we purchased it.. Little on the "dirty" side. Anyway, left side of picture, has orange(ish) looking wire going to it. You can also see the curly oil line that goes from the sender to the gauge. FYI, mine is an aftermarket gauge however the sending unit should look similar.

07-28-2011 06:38 PM
5double0 Thanks for the replies! Mine is a 90 YJ Sahara 4.2L so I did the wire at the driver's side and cleaned and re-seated but the gauge was still pegged, so I'll check the passenger side near Dizzy. Makes sense because shortly after I adjusted timing, the gauge was acting funny like a wire was loose. Can anyone post a pic?
07-28-2011 03:12 PM
kik
Quote:
Originally Posted by StinkyMud View Post
Same here.
Passenger side almost at the firewall.
07-28-2011 05:48 AM
StinkyMud
Quote:
Originally Posted by 444 View Post
On mine that's the temp sender. My oil pressure sender is near the distributor.
Same here.
07-27-2011 11:49 PM
Tat2
Quote:
Originally Posted by 444 View Post
On mine that's the temp sender. My oil pressure sender is near the distributor.
Mine too!
07-27-2011 11:30 PM
444 On mine that's the temp sender. My oil pressure sender is near the distributor.
07-27-2011 06:31 PM
5double0 Nice! Thanks! Feel free to check out my other thread regarding the Carb!
07-27-2011 06:26 PM
scott howard if you look at the very back of the driver side of the valve cover at the fire wall
you will see the sender and the purple wire hooked to it.
if this connection is loose or dirty it will peg your gauge.
07-27-2011 06:06 PM
5double0
Oil pressure sending location? 4.2L

I eyeballed the motor for where the wiring for the oil pressure sender is...not seeing it and now my oil pressure gauge is pegged all the time.
I do not have a repair manual, but most of my stuff I can do no problem...any info appreciated!

OWNS:
06 Commander 4x4 3.7l
90 YJ Sahara 4.2/nuttered/108 Motorcraft 2100 w 47 jets (not quite sure if that's the best configuration yet)/soon to do the Team Rush upgrade but with my Super stock yellow coil/rhino lined/new fuel tank/pump/filter/starter/battery/coil/dizzy cap/rotor/timing at 11 btdc

Jeeps do not get stuck...the mud just hates to let them go!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:53 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC