Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > Help wiring a subwoofer

Join Wrangler Forum Today


Thread: Help wiring a subwoofer Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-12-2011 04:59 AM
tmclaugh
Quote:
Originally Posted by Loubagger View Post
it turned out working after messing with the head unit. but about five minutes later it quit working and now i have no power to the amp. i checked the ground and 12v wires and theyre still connected. could i have just blown it that quick?
I'm sure you fixed this by now, but if not - check your fuses then use a multimeter to check for connectivity.
08-29-2011 06:46 PM
Loubagger it turned out working after messing with the head unit. but about five minutes later it quit working and now i have no power to the amp. i checked the ground and 12v wires and theyre still connected. could i have just blown it that quick?
08-29-2011 04:49 PM
TOKKIE On some head units the rca's must be turned on, look at all the settings in the head unit.
08-29-2011 04:29 PM
Loubagger i may be wrong but if it wasn't grounded properly wouldn't it not have power to the amp? I do have the remote wire, and the rca's are in the line out rear on the back of the aftermarket head unit.
08-29-2011 04:24 PM
Jma20a is it grounded properly? did you connect a remote turn on wire? RCA's? i need more info to help you out
08-29-2011 03:06 PM
Loubagger
Help wiring a subwoofer

I'm not all that knowledgeable when it comes to this stuff, but i thought i would give it a shot anyway. I have a 10 inch pioneer subwoofer and jl 500/1 amp that i would like to add in my wrangler. i have power going to the amp, but i cant get any sound from the sub. im fairly certain i have it wired correctly, but i cant guarantee it. any suggestions on what i should look for?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:51 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC