Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Issues after rain w/o top on, help needed

Join Wrangler Forum Today


Thread: Issues after rain w/o top on, help needed Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-08-2011 02:30 PM
Pmedg Hopefully i am not jinxing mself but it seems as though my Jeep just needed to dry out for a few weeks. On Friday the Jeep started right up and the CEL was off. I have not had a problem all week and there is no more sputtering at 2k RPM. It took about 3 weeks to dry out completly but that seemed to do the trick. I havent had a chance to mess with the horn issue but i appreciate the input and will update when i figure out if i need to replace the clockspring.
08-16-2011 10:28 PM
Pmedg Who is better than you!
08-16-2011 10:13 PM
Always Stuck Give me a call tomorrow. I'm on vacation this week.

I'm heading to R.I. in the morning to get two 350's running correctly on a boat. It's a 35 footer and runs like s**t, a row boat would pass it. I have two days of work there from what I've looked at already.

If I get out of R.I. early enough tomorrow or Thursday(For lack of parts) I'll pull your codes and we'll sort this out. If not I'll be at the shop Friday doing lifters on my daughter Grand Cherokee.

I'll also be down the shop this weekend repairing a fender on a truck (side work) and welding the back of a live floor trailer.

We just need to figure out a time that works and we'll..... GET ER DONE.



The fun never ends...................
08-16-2011 02:33 PM
Pmedg idk, it might not be until saturday, but i dont really need to drive anywhere till then either. accept down the street to get groceries. once i get them i will put them up
08-16-2011 02:14 PM
kjeeper10
Quote:
Originally Posted by Pmedg
i hope that its inexpensive, i will have to take a look at it. just got back from vacation and hopefully get to check it out this weekend.
Good luck.

When you getting a chance to pull the codes?
08-16-2011 01:56 PM
Pmedg i hope that its inexpensive, i will have to take a look at it. just got back from vacation and hopefully get to check it out this weekend.
08-16-2011 01:41 PM
kjeeper10 Jerry B has a write up on replacing his.
Looks easy if that is your problem
08-16-2011 01:38 PM
Pmedg excellent thanks for the info, i will look into it
08-16-2011 01:29 PM
kjeeper10 Very common especially on an older Tj was the anti drainback valve near the fuel pump to fail. There is a trick to work through the problem and I think turning the key twice like you said is part of it.
Google it-- you find some more info
08-16-2011 01:00 PM
Pmedg 44k, so very low for the year
08-16-2011 12:21 PM
kjeeper10 Probably a separate issue. Def get the codes checked, could be a slew of things.
higher miles?
08-16-2011 12:05 PM
Pmedg havent had an airbag light come on and i dont have cruise controll its a 98 sport. but the check engine light came on and it feels like power comes in and out around 2000 RPM and it takes two times to start, when before it would always start on the first try.
08-16-2011 11:01 AM
kjeeper10 Horn, airbag light on- and loss of cruise control I believe go, all three symptoms of a bad CS.

It is behind the steering wheel and allows contact for the electrical parts when the wheel is turned left & right.

My was bad before I traded the jeep away
08-16-2011 10:56 AM
Pmedg interesting, never heard of a clockspring. how would i go about checking to see if that was the case? also would that affect just the horn or would it also cause the weird fluttering of the engine around 2k RPM as well?
08-16-2011 10:04 AM
InfernoGirl I'm gonna guess that your clockspring got wet and is on it's way to failure. I may be wrong tho'. Someone else will chime in and verify or deny my instinct.
08-16-2011 09:38 AM
Pmedg
Issues after rain w/o top on, help needed

Last weekend I forgot to put the top up and it rained. I didnít think it would be an issue but since getting wet I have been having some issues that have continued long after the sun dried everything out.

First the horn went off all on its own when the car was off and eventually I pulled the wire to it and it smoked and Iím assuming shorted out, should be easy to replace.

Also when the jeep has been sitting it wont start right away, usually takes 2 turns of the key, and when it starts rev's to 2k RPM then comes back to idle.

When driving in what I think is 2nd gear around 2k RPM it will flutter until i push through it and the check engine light is on.

I havenít had a chance to have the codes pulled but Iím hoping it isnít a major issue. I'm assuming it was the rain and not a freak coincidence, but I didnít think rain would cause a problem outside of wet seats/carpets. If anyone has any ideas i would appreciate it. Thanks in advance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:47 AM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC