Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 2012 JKUR Electrical System Problem

Join Wrangler Forum Today


Thread: 2012 JKUR Electrical System Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-04-2011 08:25 PM
BattleRifle
2012 JKUR Electrical System Problem

We've had our Rubicon for 4 weeks now and LOVE IT!!! It did, however, recently have a serious problem. Four days ago the head lights would stay on during the day light and the dash/nav radio screen went into the night time dim mode. This was when the auto feature on the lighting multi-stick was chosen. Then the next day, the wiper would swipe once when starting the vehicle and would give one swipe every 40 seconds while the vehicle was running. Dealer checked it out and said that the TIPM was bad. For all of you that don't know, the TIPM (Totally Integrated Power Module) is the new name for the high-tech fuse box with a hidden lower layer of relays etc. The dealer was great. Got one next day delivery and had it installed by noon. I drove it home in the afternoon with an ear to ear proud grin with all of my music library at my every whim. So, although it's a pain to have a brand new expensive toy that needs repair. I still love my new Rubi. It rides great, tracks down the road great, has a quick spunky response and goes up hills like it could climb vertically if I tried. I just hope that this isn't a sign of more bad electrical issues to come. I'm glad it was replaced under warranty because I think the bill would have approached a thousand bucks if I had to pay for it.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:13 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC