Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Gauges don't work

Join Wrangler Forum Today


Thread: Gauges don't work Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-12-2011 12:08 PM
guardian262 Here is some info from the Factory Service Manual.

GAUGES
If an individual gauge is inoperative, see the diagnostic
procedure under the heading for that gauge. If
more than one gauge in the main cluster or gauge
package cluster is inoperative, perform the following:
(1) Check fuse 9 in the fuseblock module. If OK, go
to next step. If not OK, replace fuse.
(2) Check for battery voltage at fuse 9 with ignition
switch in ON position. If OK, go to next step. If
not OK, repair open in circuit from ignition switch
and/or refer to Group 8D - Ignition Systems for testing
of ignition switch.
(3) Turn ignition switch to OFF. Disconnect battery
negative cable. Remove the affected instrument cluster
bezel and cluster assembly. Disconnect the cluster
connector.
(4) Connect battery negative cable. Turn ignition
switch to ON. If problem is in main cluster, check for
battery voltage at cavity 3 and cavity 19 of main
cluster connector. If problem is in gauge package
cluster, check for battery voltage at cavity 2 and cavity
12 of gauge package cluster connector. If OK, go
to next step. If not OK, repair open in circuit from
fuse 9 as required.
(5) Turn ignition switch to OFF. Disconnect battery
negative cable. Probe cavities 14 and 20 of main cluster
connector, or cavities 1 and 13 of gauge package
cluster connector. Check for continuity to a good
ground. There should be continuity. If OK, replace
the cluster printed circuit. If not OK, repair open in
circuit as required.
11-12-2011 11:29 AM
W-B Brian Here is what I'm dealing with... The plug is plugged in for the center gauges which don't work. However, there are these plugs that were being the speedo and the tach which also do not work lol. I am terrible with electrical issues so any help is greatly appreciated lol
11-11-2011 03:10 PM
W-B Brian Not yet, I will check that tomorrow morning.
11-11-2011 02:48 PM
guardian262 Strange that all of them are inop. Did you check to see if the wiring harness in the back is plugged in?
11-11-2011 02:20 PM
W-B Brian I cleaned off the fuse and started her up and the gauges still didn't work. I'll take a look at it this weekend, what would be the next thing to check?
11-10-2011 04:26 PM
Garyk
Quote:
Originally Posted by YjMudslinger View Post
Wiggle ur instrument fuse around you might have some corrosion in there, that was my problem
x-2
11-10-2011 04:12 PM
YjMudslinger Wiggle ur instrument fuse around you might have some corrosion in there, that was my problem
11-10-2011 03:07 PM
W-B Brian
Gauges don't work

My gauges in my 95 2.5 don't work. Does anyone have a wiring diagram they can send me so I can check all the wiring? Also looking for other things to check. Thanks.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:44 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC