Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Startup Getting Kinda Sketchy

Join Wrangler Forum Today


Thread: Startup Getting Kinda Sketchy Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-29-2011 10:50 PM
Sammy91683 It's all good. My cousin has a complete 5000 sq. ft. shop with a hydraulic lift, and pretty much every tool you can think of. I always just go down there whenever I work on it. Thanks for the offer though :]
11-29-2011 04:56 PM
Sccafire Where in NorCal are you? If you live close enough, I have everything to help you fix your problem
11-29-2011 04:50 PM
Sammy91683 Ok sweet.
Thanks.
I'll just look up a thread/youtube video on it.
Also, if I replace all of the starter stuff, any good suggestions?
11-29-2011 08:36 AM
burton160w Wire brush & Coca-Cola and just give it hell. They also make specific wire brushes for battery terminals that make it a ten second job. Disconnect the battery before you clean the terminals

I will say that usually you can see the corrosion already on the battery if that's the problem. It'll look like a dried white crust on your terminals. But you can't be 100% sure until you take it in.

11-29-2011 08:24 AM
Sammy91683 Ok cool thanks
So just remove it and take it in? And how would I clean the posts and terminals?
11-29-2011 12:59 AM
jeepwayoflife Try what I said in the first post or 2. Look into the battery, terminals, and if nothing else the starter. Start with the battery. Get it tested at auto zone or pep boys then see how it does. Could just be the battery! Mine was.
11-28-2011 10:57 PM
Sammy91683 Ok, so I did the turning to the on position for a couple seconds thing at several different times today, and it didn't make a difference. What would be next?
11-28-2011 08:39 AM
tangofox007
Quote:
Originally Posted by HarryJeepGuy View Post
If you don't want to fix it, turn your key to the on position for 10 seconds before you start it.
The fuel pump is only going to run 2-3 seconds. No need to wait longer than that.
11-28-2011 08:25 AM
Sammy91683 Ok cool
Thanks! I'll try and figure out exactly what it is. I'll test the turning the key this morning, and if that works, then I'll know what it is
11-28-2011 08:12 AM
LiftedTj mine was doing the same thing. im to cheap and its to cold outside to fix it right now so i just turn the key forward for a few seconds, and it fires right up.
11-28-2011 01:39 AM
HarryJeepGuy Think of it as a check valve next to your fuel pump. It keeps the fuel pressure after you turn off your engine. When it goes bad, it let's the gas drain back to the tank, away from the injectors. So, when you try to start, there isn't enough gas. Turning the ignition to on fires up the fuel pump, but now it has to send gas all the way to the cylinders because the gas has drained... So either drop the tank and replace stuff, or turn the key to on and wait.
11-28-2011 01:01 AM
HarryJeepGuy After it sits for a while (overnight) you can check your pressure at the fuel rail. It sounds like your anti drain back valve is going bad near your fuel pump. If you don't want to fix it, turn your key to the on position for 10 seconds before you start it. It needs/should have pressure before starting.
11-28-2011 12:14 AM
jeepwayoflife very well could just be your battery. Same thing started happening to mine a few weeks ago. Take your battery out and bring it to a local Kragen or Pep boys and have them test it for free. As batteries die, they lose the amount of amps they can put out at once, making your starter turn slower, and making startup harder and longer. If battery fine, clean the battery posts and terminals. If still nothing, its probably the starter, but more often than not its just the battery. If STILL nothing, have the engine cleaned and yes, spark plugs replaced. Jiffy lube cleaned my engine all out for around $100 and I say a big improvement. Good luck!
11-27-2011 11:34 PM
Sammy91683
Startup Getting Kinda Sketchy

So I have a 98 TJ, and gradually, it's taking longer and longer for the engine to turn over. It has always started though. I was just wondering what part may be getting old. Do I need to get a startup replacement kit with new ignition cables and spark plugs, or what?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC