Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Puzzling Coolant Leak ???

Join Wrangler Forum Today


Thread: Puzzling Coolant Leak ??? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-25-2012 11:02 PM
TJWenatchee
Quote:
Originally Posted by tangofox007 View Post
Leaking water pump seals sometime act like that.
Good thought.
01-25-2012 11:00 PM
tangofox007 Leaking water pump seals sometime act like that.
01-25-2012 10:53 PM
TJWenatchee Sounds like something that is affected by expansion and contraction. I had a lower radiator hose that would only leak after the Jeep set for a couple of days and that was only in cool weather.
01-25-2012 10:45 PM
daynestj
Puzzling Coolant Leak ???

I have a consistent but puzzling coolant leak. I drive to work (27 miles), go out at lunch, and back home (another 27 miles) or just comparable weekend driving. After I park it - no leak. Check later that night - no leak. Check it again in the morning - no leak. Leave it setting, drive something else to work and check it when I get home - leak. It only leaks a little, about a 5-6 inch diameter circle and nothing more. It's definitely antifreeze and the only place I see any is in the bottom of the radiator housing directly under the fan where it appears to pool up and then leaks to the ground. It will do this every time I drive it if I leave it setting the next day. Any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC