Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Need help for brake lights

Join Wrangler Forum Today


Thread: Need help for brake lights Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-19-2006 08:03 PM
hardy1531 try the fuses again. I would use a multi-meter to see if you are getting any type of voltage. I have had some that appear fine but are in fact blown, couldn't tell by looking at them.
08-19-2006 07:42 PM
agriesemer I have a 95 blazer which is totally diff. from a jeep but had the exact same problem. I too changed bulbs,and the switch under the peddle and was still not fixed. but on that I guess the brake lights go through the turn signal switch ,wierd huh. but a new turn signal lever/switch fixed it I dont know if this helps, but Im sure someone out there will get some good use out of this info at some point.
08-19-2006 01:31 PM
yjswampthing
Need help for brake lights

Okay. Guy stopped me the other day and said my brake lights weren't working. So I checked all the fuses I could see under there and under the hood. None appear to be blown. My turn lights work, hazards work, and regular night time lighting works in the rear. But no brakes. So I took off the switch on the pedal thinking that would be it. Ordered a new one through napa, connected it....still no brake lights. I need help cause I can't get them to come on and there clearly isn't a bad spot in the wires or my turn and running lights wouldn't work. Is the new switch faulty? Help me out, please!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:56 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC