Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > electric problem involving radio and interior lights

Join Wrangler Forum Today


Thread: electric problem involving radio and interior lights Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-05-2012 01:03 PM
eamonn
Quote:
Originally Posted by felix225 View Post
If the dash is saying no fuse..its usually the 20 amp fuse for the memory side of the ECM..atleast on the SRT4 i had it was..had a yellow plastic thing surrounding it...
i tried to check for that fuse but didnt see anything like that...is it in the fuse box in the engine boy or behind the glove box
02-03-2012 12:17 AM
eamonn
Quote:
Originally Posted by Kevbz View Post
fuse 20 and 24 are good under the hood on the passenger side?
yeah im pretty sure i checked all the fuses...ill check again tomorrow though
02-02-2012 11:09 PM
eamonn
Quote:
Originally Posted by felix225 View Post
If the dash is saying no fuse..its usually the 20 amp fuse for the memory side of the ECM..atleast on the SRT4 i had it was..had a yellow plastic thing surrounding it...

hmmm ill have to check that out cause yeah its flashing saying that and not power to radio or lights hopefully yourright haha
02-02-2012 06:28 PM
felix225 If the dash is saying no fuse..its usually the 20 amp fuse for the memory side of the ECM..atleast on the SRT4 i had it was..had a yellow plastic thing surrounding it...
02-02-2012 10:51 AM
Kevbz fuse 20 and 24 are good under the hood on the passenger side?
02-02-2012 10:29 AM
eamonn
Quote:
Originally Posted by Kevbz View Post
what year? the dome and lower lights are on the same circuit so it should be a easy fix
its a 2001
02-02-2012 09:46 AM
Kevbz what year? the dome and lower lights are on the same circuit so it should be a easy fix
02-02-2012 09:39 AM
eamonn
electric problem involving radio and interior lights

ok so the other day my battery died in the jeep on a rainy day so i open the hood and replace the battery and as i finished i noticed water was dripping onto the jeeps computer and i though nothing of it so then i go to start the car for the first time since the battery was replaced and it starts right up and headlights everything works EXCEPT im getting a light on my dash flashing saying no fuse and the radio, lights by the floor, and the dome light arent going on and i checked like every fuse and they are all good so im completely stumped on what the problem could be. if anyonw could help id greatly appreciate it

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:11 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC