Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > What I did to my TJ today

Join Wrangler Forum Today


Thread: What I did to my TJ today Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Today 07:17 PM
MyRed88
Quote:
Originally Posted by LKSPIERS View Post
Relocated license plate and hooked my cb up
if I ever run 37s or bigger I'll do this
Today 07:04 PM
srad600 Yeah looks great
Today 07:01 PM
LKSPIERS
Quote:
Originally Posted by srad600 View Post
I like the look of the plate there but can't imagine being with out a spare.
One day I'll put a spare back but for now I like the look
Today 06:33 PM
srad600 I like the look of the plate there but can't imagine being with out a spare.
Today 06:17 PM
LKSPIERS Relocated license plate and hooked my cb up
Today 05:48 PM
Burddog Here is the front
Today 05:47 PM
Burddog Gave my baby a Plasti-dip bra and finished putting her back together after covering the inside with Herculiner.
Today 02:58 PM
IIONLY Adjusted my brake shoe star wheels, adjusted the hand brake cable, cleaned the rotors and drums (hoping it would help stop my squeal, it didn't), rotated my tires and sprayed underneath with some asphalt undercoating. Was going to change my spark plugs but my plug socket and gap tool have disappeared. So guess that may happen next week. Also gave "the tank" a nice wash. It was a good day.
Today 07:27 AM
Muddeprived
Quote:
Originally Posted by wwch99tj View Post
I bought one of the cheap fenders a couple years ago, I wasn't too impressed with the fit. I had to oval the holes on the body side,
drill the hole on the top at the grill... (circled in pic)

I was changing front stock flares to Sahara flares at the time, but the fender didn't have enough metal bent down around the radius in front for the flare to reach (area circled in pic)


And the fender seems to have a slight arch to it, the hood hits the middle of it...
I can get a pic of this tomorrow if you want.
I better test fit mine just to be sure. How difficult was it to remove the factory fenders?
Yesterday 08:29 PM
Momamac I did 3/8" holes. Figured 1/4" may be too easy to get plugged up.
Yesterday 08:12 PM
PantherWingsfan
Quote:
Originally Posted by Momamac View Post
Drilled drain holes in the frame, wire brushed the minimal rust on the outside and rustoleumed it. Next step, vacuum out the frame...have 4 cans of Eastwood Internal Frame Coat at the ready! Frame still solid and thick, want to keep it that way!
I've been cleaning and painting mine as well. Curious, what size holes did you drill?
Yesterday 07:58 PM
wwch99tj
Quote:
Originally Posted by Muddeprived View Post

I did a bunch of reading on reviews and everyone who bought their fenders say they fit perfectly so I have high hopes mine will to. They are identical to my stock ones, only no rust.

I wonder what I can do about the rust-prone area under the fender? There's like a flat plate welded under it I guess for support and I can see how salt/water/mud gets stuck up inside causing the rust.
I bought one of the cheap fenders a couple years ago, I wasn't too impressed with the fit. I had to oval the holes on the body side,
drill the hole on the top at the grill... (circled in pic)

I was changing front stock flares to Sahara flares at the time, but the fender didn't have enough metal bent down around the radius in front for the flare to reach (area circled in pic)


And the fender seems to have a slight arch to it, the hood hits the middle of it...
I can get a pic of this tomorrow if you want.
Yesterday 07:43 PM
srad600
Quote:
Originally Posted by Momamac View Post
Drilled drain holes in the frame, wire brushed the minimal rust on the outside and rustoleumed it. Next step, vacuum out the frame...have 4 cans of Eastwood Internal Frame Coat at the ready! Frame still solid and thick, want to keep it that way!
I wish some one who owned mine before me did something like this. I've repaired mine in mode places then I can count now. Not sure if its worth doing anything at this point.
Yesterday 07:32 PM
Momamac Drilled drain holes in the frame, wire brushed the minimal rust on the outside and rustoleumed it. Next step, vacuum out the frame...have 4 cans of Eastwood Internal Frame Coat at the ready! Frame still solid and thick, want to keep it that way!
Yesterday 07:29 PM
PantherWingsfan
Quote:
Originally Posted by Holton345 View Post
I too have wondered this. Seems to me that nothing under there needs to breath. Perhaps sealing off every seam, gap and crevice with RTV and then priming and painting or bedlining might take care of that. You would have to mask off a lot, though. I had my fenders off recently and it looked pretty do-able to me. If it worked the payoff would be no more rotted fenders...
Sounds like a good idea. I considered after market designs but I couldn't find any I really liked. In MI mine are definitely salt victims.
Yesterday 06:54 PM
Holton345
Quote:
Originally Posted by Muddeprived View Post
I wonder what I can do about the rust-prone area under the fender? There's like a flat plate welded under it I guess for support and I can see how salt/water/mud gets stuck up inside causing the rust.
I too have wondered this.

Seems to me that nothing under there needs to breath. Perhaps sealing off every seam, gap and crevice with RTV and then priming and painting or bedlining might take care of that. You would have to mask off a lot, though.

I had my fenders off recently and it looked pretty do-able to me. If it worked the payoff would be no more rotted fenders...
Yesterday 06:37 PM
PantherWingsfan A little before and after of the fender paint job.
Yesterday 06:03 PM
Muddeprived
Quote:
Originally Posted by PantherWingsfan View Post
Not far off on my to do list. Id love to hear how they line up with everything during install. Keep us updated!
I did a bunch of reading on reviews and everyone who bought their fenders say they fit perfectly so I have high hopes mine will to. They are identical to my stock ones, only no rust.

I wonder what I can do about the rust-prone area under the fender? There's like a flat plate welded under it I guess for support and I can see how salt/water/mud gets stuck up inside causing the rust.
Yesterday 06:01 PM
PantherWingsfan
Quote:
Originally Posted by Muddeprived View Post
Received my two brand new fenders from ebay. Everything looks intact and gonna take em to get painted soon.
Not far off on my to do list. Id love to hear how they line up with everything during install. Keep us updated!
Yesterday 05:45 PM
Muddeprived Received my two brand new fenders from ebay. Everything looks intact and gonna take em to get painted soon.
Yesterday 05:22 PM
PantherWingsfan
Quote:
Originally Posted by raif281 View Post
nice repaint job
Thanks! Did the flares too. What a difference!
Yesterday 04:17 PM
raif281 nice repaint job
Yesterday 02:28 PM
PantherWingsfan Fresh coat of paint on the bumpers. Much better!
Yesterday 02:18 PM
gnater76 Installed Rokmen gearbox skid and Novak xfer case cable. Holy smooth as butter!!! Wish id done that ages ago. If you only do one mod to your rig, do the cable. Unbelievable how smooth and easy it is now!!!!!
Yesterday 03:32 AM
JustinAppleseed
Quote:
Originally Posted by Holton345 View Post
The D30 U-joints kicked my ass. They were so badly stuck and rusted that the ears of the shafts ended up getting bent. The bends are so minor that I cannot see them, but the caps will NOT line up right on two of them (right inner, left outer). I have now destroyed two Spicer 5-760X U-joints trying to get them in on one side each time. Three caps seat perfectly on each side, but one bore has been bent on each axle shaft combo and the caps keep shattering. (No, no bearings fell over. The shaft ears are actually bent according to my micrometer and calipers, but I cannot *see* the bend.) Damn. So I just bought a set of alloys off Amazon. I hope they are good. I am deficient in my knowledge of axle shafts. I know I want to beef up my D 30, but the cost had me putting that off, but the OEM Jeep parts are even more expensive! I'll be damned if I drop that sort of coin on parts with a known failure rate like the stock shafts have! So I got this kit: http://www.amazon.com/Alloy-USA-1214.../dp/B000FQ08MO It comes with China-made U-joints that I do not trust. I trust the shafts based on what I have read here, but not those U-joints. So I added in a pair of Spicer 5-760X joints. And I fully expect to have them press in PERFECTLY for that price! HAHAHA!!! Anyone here have this kit or at least the Alloy USA 27 spline shafts? Please tell me I didn't just buy a big box of crap...
I have the 30 Spline inner with 27 Spline outer version of that kit, & the 30 Spline rear kit as well.. ARB's front & rear, all Timken bearings, Timken hubs, & CTM joints.. Been running this for 2-3 months now on 35's & no issues or complaints... If I somehow twist one? It will be an excuse to get a set of Revolution axels when they come out.
08-30-2014 11:51 PM
BuzzinHornets Today I replaced the cooling system. Radiator, water pump, thermostat, thermostat housing, temp sensor, hoses, belt and idler pully. Fingers crossed I have no leaks and I don't have to mess with it again for quite some time!
08-30-2014 10:43 PM
Holton345 The D30 U-joints kicked my ass. They were so badly stuck and rusted that the ears of the shafts ended up getting bent. The bends are so minor that I cannot see them, but the caps will NOT line up right on two of them (right inner, left outer). I have now destroyed two Spicer 5-760X U-joints trying to get them in on one side each time. Three caps seat perfectly on each side, but one bore has been bent on each axle shaft combo and the caps keep shattering. (No, no bearings fell over. The shaft ears are actually bent according to my micrometer and calipers, but I cannot *see* the bend.)

Damn.

So I just bought a set of alloys off Amazon. I hope they are good. I am deficient in my knowledge of axle shafts. I know I want to beef up my D 30, but the cost had me putting that off, but the OEM Jeep parts are even more expensive! I'll be damned if I drop that sort of coin on parts with a known failure rate like the stock shafts have! So I got this kit:

http://www.amazon.com/Alloy-USA-1214.../dp/B000FQ08MO

It comes with China-made U-joints that I do not trust. I trust the shafts based on what I have read here, but not those U-joints. So I added in a pair of Spicer 5-760X joints. And I fully expect to have them press in PERFECTLY for that price!

HAHAHA!!!

Anyone here have this kit or at least the Alloy USA 27 spline shafts? Please tell me I didn't just buy a big box of crap...
08-30-2014 10:07 PM
Owen_TJ
Quote:
Originally Posted by traveler0197 View Post
I installed my Poison Spyder Hood Louver. The first of many more mods.
Kinda puckers the butthole before you make the first mark, huh lol. Looks great, man...did mine a couple weeks ago.

But for today...i ordered my new UCF tummy tuck and cable shifter!!! Cant wait...
08-30-2014 09:58 PM
ZLSeth Ok... It wasn't today.... A week ago, I installed my Trek Top NX, so now I can sell all of my other tops: Bestop bikini with header, factory soft top in decent condition and hard top (currently missing rear window due to trail damage).
08-30-2014 09:07 PM
PantherWingsfan Already a million times better. One down. Three to go!
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC