Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Jeep does some hesitation while cold

Join Wrangler Forum Today


Thread: Jeep does some hesitation while cold Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-19-2012 07:26 PM
WaterDR I doubt the TB is dirty. The idle air controller (iac) though might be a different story.

I will take a picture of it for you.
03-19-2012 10:37 AM
Gorving3 Changing a sensor would be no problem, I know what they look like and where they are. But I'm not sure what is meant by cleaning the throttle body, where the cleaning needs to be done, or how to do it. Is there any explanation anyplace on the Forum or other web sites?

Thanks.
Allen
03-18-2012 11:57 PM
WaterDR The reason why I think going to full throttle tests the O2 sensor is because the computer goes into open loop and does not use the sensor to control fuel addition.
03-18-2012 10:51 PM
Gorving3 Thanks for the response Kevin. Don't usually give it full throttle before a good warm up and by that time any hesitations are usually not there. This hesitation us generally just under slight throttle pressure during the first few blocks. Next outing I'll try letting it warm up in the driveway then give it a good run right off first thing to see if it hesitates then.

Allen
03-18-2012 06:36 PM
Kevinw23 No expert here, but I had a similar problem and after a few replies, guys helped me solve my problem. I replaced the upstream O2 sensor and cleaned the throttle body. Not sure which one fixed the problem, but its gone. Been driving the car for two weeks and no hesitations at all. I believe.....but don't quote me, that if you give the jeep full throttle and it DOES NOT hesitate, then its the sensor....and that was the case with mine. Just cleaned the TB as a precautionary measure. Again, I am no expert, just what worked for me.

Kevin
03-18-2012 05:15 PM
Gorving3
Jeep does some hesitation while cold

After a cold start up (anywhere from 20-60 degrees) there will be a couple of slight hesitations during acceleration the first block or two. If it were a carburetered engine I'd think either the accelerator pump was bad or the choke was hanging open but being a 2001 4.0 engine that can't be the case. Installed new Autolight APP plugs about 2,000 miles ago.
After a couple miles warm up everything runs smooth as silk.
Any suggestions as to what might be going on? I've tried to avoid any 10% ethanol gas but sometimes forget and have also noticed some stations will have it posted on one pump but not the other. Should ask why but most clerks don't know what's put in the tanks.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:16 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC