Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Rough country lift install question

Join Wrangler Forum Today


Thread: Rough country lift install question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-22-2012 06:17 PM
misfitartist Hey did you steal my jeep when I wasn't lookin lol. Well bad news the n 2.0 shocks ripped my rear shock mounts right in half today. The mounts weren't weak or have any cracks in them either i went down a real easy dirt road and when I got back both shocks were hanging and one was bent
03-22-2012 08:08 AM
wranglerbrother WOW, this reminds me of my jeep right after my install of the 4"rc lift.. and yes, its probably that the shackles just had to settle.. mine did the same thing and now they are completely vertical. check out this pic lol.. looks sooo similar to mine before my big tires.. and u can see the shackles facing in on mine in this pic too.. this is right after the install like 2 months ago or something.. check out the thread in my sig to see how it looks now :P
03-21-2012 10:22 PM
misfitartist Well I got there today and the springs settled overnight and the shackles were right where they were supposed to be got the front half of the lift done all that's left is changing the pitman and cutting the tunnel out to allow for shifting but other than that took it out and tested it and wow what a difference in the ride quality over stock and it handled down the trails real nice too can't wait to get the 33s for it now and throw it in some mud to try it out.
03-21-2012 08:07 PM
Aintscurred With everything loose and sitting on the ground take a pry bar between the shackle and frame and pry it out. When you get the shackle to sit straight vertical then tighten everything down. Just installed the same lift 3 months ago.
03-21-2012 07:20 PM
mcseang you have to cycle the suspension with the bolts left loose, just stand on the rear bumper and bounce up and down then do the same with the front.
the shackles will rest in the correct position after that
03-21-2012 03:55 PM
gohounds I have the 2 1/2 the rear springs did the same thing, they cam forward I set it on the floor and used a pry bar to cam past center (towards back of jeep) then tightened everything and they stayed.
03-21-2012 10:47 AM
misfitartist That was my other thought that maybe the springs need to get broken in some and settle. I'll post pics later when I get to the garage and get the front half of the lift in
03-21-2012 10:08 AM
ARod0411 Agree, unless something is really wrong, the shackles will begin to settle once the Jeep's weight is on them and after you drive it the shackles shall return to near their original position.
03-21-2012 10:05 AM
Ibuildembig I will settle down after you drive it....or at least every one I have done has
03-21-2012 10:05 AM
ARod0411 Misfit, had the same deal when I installed my lift. However, once I set it back on the ground, bolts loose, with the Jeep's weight the shackles began to return to their normal position as the original.
03-21-2012 09:59 AM
95YamJam Pics would help too. Def sounds like they are facing the wrong way.



I also have to say not to torque the springs shackle bolts to 90 ft lbs. 45-50 is waaaaaaayyyyyy better.
03-21-2012 09:58 AM
misfitartist Nope left everything loose on it set it on the ground nothin changed still haven't tightened anything incase something needs to be changed
03-21-2012 09:42 AM
Ibuildembig Sounds like you tightened the shackle bolts before the weight was down on it.
03-21-2012 09:38 AM
Beachcruiser Sounds odd.....YJ springs are the same length, front & rear. Were the new springs same length?

I've never installed that brand lift...but it seems strange that it would have effected one end & not the other.
03-21-2012 07:48 AM
misfitartist
Rough country lift install question

Ok I got the rough country 4 inch lift kit for my 95 took almost the whole day yesterday to rip apart the back and get the new springs and shocks in. Every single bolt in my jeep was seized and would not come out what a nightmare that was.

My question is I got the new lift springs in and the shackles in the rear are now turned all the way forward and it just don't look like it will work right that way. The stock springs the shackles were turned towards the back around 20 degrees from vertical. Shouldn't that be how the lifted springs sit too. If so should I make a new mounting location for the shackles in the frame.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:48 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC