Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Clutch problems on 94'

Join Wrangler Forum Today


Thread: Clutch problems on 94' Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-08-2008 10:50 PM
txjustin You might as well get a clutch kit...they are not that expensive. I am getting mine for about $140 for the kit.
04-08-2008 08:53 PM
jpdocdave hi and welcome, if its not the actual pedal linkages squeaking, which it probably isn't. then you'd have to remove trans, and if you do that, might as well replace the clutch if it hasn't been done yet. there's a few moving parts that have a special grease on them, probably where the clutch fork pivots or moves on the shaft is squeaking. good luck and let us know
04-08-2008 08:30 PM
1BLKJP Hi there, I moved this thread into the correct area for you. Your 1994 is a YJ Wrangler not a CJ.
04-08-2008 06:32 PM
94-stick-wrangler
Clutch problems on 94'

this may not seem much to some ppl but i love my 94' to bits and try and keep him in perfect order but one thing has been annoyin me for ages which is the squeeky clutch. i have tried to solve it myself but no luck have also take it to the mechanics and they say they cant access it to oil it but, then again they also said i needed a new radiator when they just replaced it with a brand new one the month before. can any one help me out?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:53 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC