Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > I believe I fixed the suspension noise

Join Wrangler Forum Today


Thread: I believe I fixed the suspension noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-23-2012 10:07 PM
4fit
Quote:
Originally Posted by Rooster454 View Post
Thanks again for your input sir. I was unsure on which route to take and you certainly helped a lot.
Not a problem. Glad to help.
03-23-2012 10:05 PM
Rooster454
Quote:
Originally Posted by 4fit View Post
Glad to hear you got it handled! Hoping to track down my driver's side suspension rattle sometime this weekend.
Thanks again for your input sir. I was unsure on which route to take and you certainly helped a lot.
03-23-2012 10:00 PM
4fit Glad to hear you got it handled! Hoping to track down my driver's side suspension rattle sometime this weekend.
03-23-2012 09:44 PM
Rooster454
Quote:
Originally Posted by Wharfrat View Post
Nice work dude. Amazing how simple it can be sometimes. Thinking its about time for a new torque wrench myself. The 5 year old harbor freight one is showing its age.
Amazing AND frustrating, but all part of the game.

I just bought a new torque wrench as well. Nothing like a good straining session getting those CA bolts to 125 lbs.

Quote:
Originally Posted by kbwwolf View Post
Not sure how I missed this: Weird popping noise in front suspension

Glad you got it fixed.
Me too man. It had me worried that I was going to have to spend some of my tire money to get something fixed and put me behind my goal date for getting tires and nobody wants that

Ended up being a simple fix luckily
03-23-2012 08:05 PM
kbwwolf
Quote:
Originally Posted by Rooster454 View Post
I just wanted to say thanks to everybody that gave me advice on what might fix the popping noise. I got home from work early and re-loosened all the CA bolts and trackbars(finally got the front loose), gave it a GOOD shake and then re-torqued everything to spec and the popping seems to have gone away.

Now the bad part is I have no idea what it was, but THINK it was the lower control arm bushing on the drivers side as that's where the sound seemed to be coming from.

Thanks again for all the help. I feel alive again
Not sure how I missed this: Weird popping noise in front suspension

Glad you got it fixed.
03-23-2012 08:01 PM
Wharfrat
Quote:
Originally Posted by Rooster454
I just wanted to say thanks to everybody that gave me advice on what might fix the popping noise. I got home from work early and re-loosened all the CA bolts and trackbars(finally got the front loose), gave it a GOOD shake and then re-torqued everything to spec and the popping seems to have gone away.

Now the bad part is I have no idea what it was, but THINK it was the lower control arm bushing on the drivers side as that's where the sound seemed to be coming from.

Thanks again for all the help. I feel alive again
Nice work dude. Amazing how simple it can be sometimes. Thinking its about time for a new torque wrench myself. The 5 year old harbor freight one is showing its age.
03-23-2012 06:35 PM
Rooster454
I believe I fixed the suspension noise

I just wanted to say thanks to everybody that gave me advice on what might fix the popping noise. I got home from work early and re-loosened all the CA bolts and trackbars(finally got the front loose), gave it a GOOD shake and then re-torqued everything to spec and the popping seems to have gone away.

Now the bad part is I have no idea what it was, but THINK it was the lower control arm bushing on the drivers side as that's where the sound seemed to be coming from.

Thanks again for all the help. I feel alive again

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC