Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Radio dead.. help

Join Wrangler Forum Today


Thread: Radio dead.. help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-28-2012 08:23 PM
Renaissance_Redneck My radio "dies" on a regular basis, and ONLY after I've started it with the "remote start" feature on my '10. Though I've never counted, it seems to die after I've remote-started the Jeep a couple dozen times or so. It'll be fine for a while, then after a number of remote-starts, it will die again. Typically the radio will start up again after stopping and re-starting with the key 3 or 4 times. Odd; I have no idea why it does this.
03-28-2012 01:51 PM
JeeperJake My 08 radio 'died' a couple times in the last year. It was totally inert of unknown causes. After fiddling a few times with ALL the buttons, it suddenly kicked back into life again.

Maybe "3" events, dead a total of 5-60 minutes each time.
No idea why or what. So far, so good.

Fortunately I'm passed the point where having one matters much.

Had XM radio for about 6-7 years. Got to be more hassle than enjoyment, and the price kept climbing too.

Commercial radio is about 1/3 well..."commercials"....and I don't listen to them....then about 1/3 of what I hear I tune away from....so about 1/3 of the time I don't want it on anyway. That leaves very little time that I want what used to be a MUST have option.
03-28-2012 01:44 PM
real4x4 check the volume and the on/off button
03-28-2012 01:42 PM
Jpxfactor Thanks .. I checked the fuses .. were ok.. pulled negative battery cable for a couple of minutes and it's working normal again.
03-28-2012 11:05 AM
snikt Check the fuses?
03-28-2012 11:03 AM
Jpxfactor
Radio dead.. help

Started up my 08 X today .. radio is dead .. help .. need my tunes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:40 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC