Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion > New Jeep Owner (Needing Guidance!)

Join Wrangler Forum Today


Thread: New Jeep Owner (Needing Guidance!) Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-31-2012 09:38 PM
BT To me it sounds like it just needs a tune up. If that doesn't fix it then at least you got that out of the way and then you know it's something more serious.
03-31-2012 05:22 PM
SirBuddlyLongFellow
Quote:
Originally Posted by bta2011 View Post
Welcome to WF!

My YJ sputtered and idled rough for a few weeks. Even stalled on me a few times. 4.0 I6 Auto trans. My father and I did a good tune up(Plugs and wires, oil change, and a fuel system treatment.) and she has ran like champ even since! Might give that a try before replacing a part that may not need replacing. Just a thought
I'm new to forums in general, but this place is awesome! I love the Wrangler community! Thanks a lot guys for the advice! Now I have hope that it's not a major issue!
03-31-2012 03:39 PM
BT Welcome to WF!

My YJ sputtered and idled rough for a few weeks. Even stalled on me a few times. 4.0 I6 Auto trans. My father and I did a good tune up(Plugs and wires, oil change, and a fuel system treatment.) and she has ran like champ even since! Might give that a try before replacing a part that may not need replacing. Just a thought
03-31-2012 01:35 PM
Beastmaster Sounds like the fuel pump to me but I'm not real familiar with TJs.
I'd suggest you post here: TJ Jeep Wrangler Forum - Jeep Wrangler Forum

I think you'll get more answers there.

In the mean time . . .

Welcome to the forum!

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
03-31-2012 08:33 AM
SirBuddlyLongFellow
New Jeep Owner (Needing Guidance!)

Hello, Just bought my first Wrangler (I've always wanted one, and I love having it), but it feels like it's lagging, or sputtering and that the gas isn't getting to it right away. Feels like maybe a fuel pump problem? Also, it has stalled on me while going from Reverse to Drive (backing out of driveway). Is the fuel pump the culprit? Or is it going to be much more complicated/costly than that?

Jeep is a 98' Sahara 130K miles, 6 Cyl 4.0 Liter

Also, I'm new to the 'WranglerForum' so I don't know if I'm using this correctly and if anyone can see this...?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC