Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion > Air conditioning in 2010th JK Wrangler

Join Wrangler Forum Today


Thread: Air conditioning in 2010th JK Wrangler Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-09-2012 06:39 AM
Mathius No leaks though, bloody frustrating that's all!!
04-08-2012 11:54 PM
blackforestgreen first thing that comes to my mind is antifreesze leak.
04-07-2012 05:16 PM
Mathius Hiya, no overflow for coolant is all ok, dealer said nothing wrong in the system when they used the diagnostics tool though that was before I noticed there was a reduction. Back to the jeep dealer again I guess.
04-07-2012 04:47 PM
div4gold Could it be blowing coolant out of the overflow tank?
04-07-2012 08:57 AM
KBR97 Maybe it sprung a leak somewhere under the hood. I would take it in to get checked. If its a leak it will be covered under warranty.
04-07-2012 07:26 AM
Mathius
Air conditioning in 2010th JK Wrangler

Noticed a hissing noise that occasionally sounded behind the centre vents and then not long ago it was like a pressure valve released and there was steam coming out from the base of the engine compartment, this went for about 20 seconds while the jeep was idleing. It happened again just a few days ago and it seems as though the air conditioning has lost its chill factor. I have had it from new for 16 months and wouldn't think it would need re gassing already. Does anyone have ideas on what this may be or if maybe the air con filter can be inspected? Any help will be appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:40 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC