Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Clicking noise on a 2012 4Door JK with 2" Mopar lift.

Join Wrangler Forum Today


Thread: Clicking noise on a 2012 4Door JK with 2" Mopar lift. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-24-2012 09:46 PM
shelfrich Fixed the problem!! The rear left spring moved back in its housing and was popping on the nut holding the rear sway bar bracket.. now i just gotta figure out if the spring moving in the housing is a normal thing or not..
04-22-2012 04:02 PM
kjeeper10 Keep us posted
04-22-2012 12:00 AM
shelfrich
Quote:
Originally Posted by kjeeper10 View Post
I would go through and check the torque on all suspension bolts.
Yeah, I might have to now. Hopefully thats all thats wrong.
04-21-2012 11:09 PM
kjeeper10
Quote:
Originally Posted by shelfrich

Im running pro comp model # 7089 16x8 4.5 back spacing
I would go through and check the torque on all suspension bolts.
04-21-2012 11:04 PM
shelfrich
Quote:
Originally Posted by kjeeper10 View Post
Sway links

Or the rear. What wheels are you running?
lifted JK's the rear link is very close to the stock wheel.
But it think that would be noticed going over a bump or uneven terrain.

Take some pics if you can
Im running pro comp model # 7089 16x8 4.5 back spacing
04-21-2012 11:00 PM
shelfrich Yeah im 99% sure its from the rear, i believe fron the left side also, i had two people in the car that though the same thing also. Its not a "clicking" noise i should have said a single click noise, its more of a pop. It sounded like from the left rear, i had someone in the back seat and he could hear it through the floor board behind my seat. When we got home i stood on the rear bumper and made the jeep move up and down and couldnt get it to do it, i also made it sway from side to side and it didnt do it. it only happens when im in motion and turn the wheel sharply to the right.

Quote:
Originally Posted by kjeeper10 View Post
Sure its coming from the rear?

Odd because it happens when you turn.
"clicking" is usually u-joints but low miles ??
04-21-2012 10:54 PM
kjeeper10
Quote:
Originally Posted by Comac90

That's tough to diagnose online ... Start by re-checking all the suspension link bolts starting with the swaybars. Even though you think it's in the rear, check to ensure your front sway bar isn't hitting the round frame crossmember that comes all the way through the frame and into the front wheelwells. That seems to be a relatively common problem on lifted JKs. If that's the case, you'll just need to grind the crossrail down.

T
Sway links

Or the rear. What wheels are you running?
lifted JK's the rear link is very close to the stock wheel.
But it think that would be noticed going over a bump or uneven terrain.

Take some pics if you can
04-21-2012 10:48 PM
Comac90
Quote:
Originally Posted by shelfrich View Post
I have a 4 door JK with 1400 miles on, I just got my 2" OEM lift with my 33" BFG KO's on a few days ago and I went on some trails today and noticed a weird clicking noise in the rear end whenever I turn the wheel to the right going about 20-40mph. It's almost a popping noise. I didnt do anything to crazy. If i go over a speed bump it didnt do it, its only when i turn the wheel to the right kinda sharply. What could it be? the lift only has about 300 miles on it. While off roading I didnt bottom out, or get air born, there was a couple times i was close to doing both though. Please help!
That's tough to diagnose online ... Start by re-checking all the suspension link bolts starting with the swaybars. Even though you think it's in the rear, check to ensure your front sway bar isn't hitting the round frame crossmember that comes all the way through the frame and into the front wheelwells. That seems to be a relatively common problem on lifted JKs. If that's the case, you'll just need to grind the crossrail down.

T
04-21-2012 10:47 PM
kjeeper10
Quote:
Originally Posted by shelfrich
I have a 4 door JK with 1400 miles on, I just got my 2" OEM lift with my 33" BFG KO's on a few days ago and I went on some trails today and noticed a weird clicking noise in the rear end whenever I turn the wheel to the right going about 20-40mph. It's almost a popping noise. I didnt do anything to crazy. If i go over a speed bump it didnt do it, its only when i turn the wheel to the right kinda sharply. What could it be? the lift only has about 300 miles on it. While off roading I didnt bottom out, or get air born, there was a couple times i was close to doing both though. Please help!
Sure its coming from the rear?

Odd because it happens when you turn.
"clicking" is usually u-joints but low miles ??
04-21-2012 10:38 PM
shelfrich
Clicking noise on a 2012 4Door JK with 2" Mopar lift.

I have a 4 door JK with 1400 miles on, I just got my 2" OEM lift with my 33" BFG KO's on a few days ago and I went on some trails today and noticed a weird clicking noise in the rear end whenever I turn the wheel to the right going about 20-40mph. It's almost a popping noise. I didnt do anything to crazy. If i go over a speed bump it didnt do it, its only when i turn the wheel to the right kinda sharply. What could it be? the lift only has about 300 miles on it. While off roading I didnt bottom out, or get air born, there was a couple times i was close to doing both though. Please help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC