Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Another dumb question - flush of water sound when starting my 12 JKU

Join Wrangler Forum Today


Thread: Another dumb question - flush of water sound when starting my 12 JKU Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-11-2012 08:21 PM
SilverSport Quite alright.
10-11-2012 08:18 PM
Paul10
Quote:
Originally Posted by SilverSport View Post
Thermostat is located on front of engine; follow upper hose from radiator to engine.
Thanks..will check. I think I posted in 2 threads...doh.
10-11-2012 08:06 PM
SilverSport Thermostat is located on front of engine; follow upper hose from radiator to engine.
10-11-2012 07:34 PM
Paul10
Quote:
Originally Posted by SilverSport View Post
The 3.6L also has a bleeder screw located in the thermostat housing.
Where is this? My 2013 sport started making the water sound. Must be air in the system.
09-19-2012 08:25 AM
ksdindy Sorry, here's the link

http://www.wranglerforum.com/f33/fyi...er-186603.html
09-12-2012 03:38 PM
ksdindy Problem diagnosed awaiting resolution...

http://www.wranglerforum.com/newthre...newthread&f=33
09-12-2012 02:37 PM
GiantSchnauzer I usually hear that sound from the passenger side when a person rides in my jeep with me for the first time! but joking aside I hope they get that fixed.
09-12-2012 10:05 AM
dukedallas O dont worry that sound is coming from your wallet, its the sound of all the money you'll be spending on your Jeep mods. ;-) LOL BTW hope it gets resolved !
09-12-2012 09:58 AM
Crushed Mine does this as well, and interestingly enough the 2011 WRX that I bought brand new last year did it as well. Nothing ever came of it on the WRX before I traded it in on the Jeep. I'll see if I can try idling it on an incline to see if that does anything.
09-12-2012 09:43 AM
ksdindy My "water sound" was becoming more regular - even after the vehicle warmed up. So, I took my car in on Monday morning to get it looked at. They thought it might have something to do with the evaporator drain. Later that day, after they had the dash apart, they found that that was ok, but the sound was definitely coming from the Heater Core although it wasn't leaking. Yesterday, they said they needed to get approval from Chrysler to replace it because if they replaced the core and sent the part back and it wasn't defective, Chrysler would charge them for it. So, they said it might be a few more days and they would get me a rental. So, they sent a van from the dealership to pick me up and take me to Enterprise. They dropped me off at Enterprise but they said 1) the dealership never notified them that I was coming to get a car and 2) they didn't have any cars to give me. Enterprise drove me back to the dealership where I waited an hour and a half for them to find me a car.

Finally got a rental Tuesday evening - unfortunately, a little Toyota Yaris, but at least I'm mobile again.

Today is Wednesday and we'll see whether or not they fix the core and how long it takes.
08-15-2012 06:24 AM
Mike1972chev
Quote:
Originally Posted by ksdindy View Post
Just noticed this, but when I turn on the key it seems as though I hear water rushing somewhere behind the glove compartment. Is this normal and why am I just now starting to hear it?

Thanks for putting up with such a newb!
I wouldnt even really worry about this one. Only time to worry is if you start getting coolant in your floorpans inside with you! lol.
08-14-2012 08:21 PM
SilverSport The 3.6L also has a bleeder screw located in the thermostat housing.
08-14-2012 06:10 PM
unionjewel Someone mentioned that there's a whole other thread on this. The radiator needs to be "burped" to let the air out of the cooling system. There's even a youtube video on it. Check it out.

Burping the cooling system - YouTube
08-14-2012 02:51 PM
SilverSport
Quote:
Originally Posted by WXman View Post
So did anybody ever find a resolution to this issue? My '12 is doing the same thing. Start the engine and it sounds like a water fountain is running behind my glove box. Should I take it to the dealership or is this "normal"?
I thought someone mentioned in another thread there is a TSB out for this. Take it to the dealer so at a minimum you can get it documented.

The dash isn't too complicated. I watched one get taken a part. A good tech can do it without fudging anything up.
08-14-2012 02:46 PM
oilwell1415 How uphill is that? I'm talking about front wheels 2 feet higher than the rears. And it will need to be running, not just parked.
08-14-2012 02:21 PM
WXman Ok cool. Ironically, I park the Jeep uphill (nose first) every night. It's been nearly 3,000 miles now but I'll give it some more time and hopefully it'll cure itself.
08-14-2012 12:59 PM
Lynskey After a couple of months the rushing fluid noise went away. I suspect the air gap finally purged out to the reservior. Nice and quiet now.
08-14-2012 09:14 AM
oilwell1415
Quote:
Originally Posted by chim-chim7 View Post
Check the coolant level when cold. You may have a air pocket.
This....

Quote:
Originally Posted by Lynskey View Post
I recommend you NOT have the stealership rip it apart.
...and this. Taking a dash apart to change a heater core is asking for trouble. I wouldn't touch it until it starts pissing in the floor or the heater quits.

Quote:
Originally Posted by WXman View Post
So did anybody ever find a resolution to this issue? My '12 is doing the same thing. Start the engine and it sounds like a water fountain is running behind my glove box. Should I take it to the dealership or is this "normal"?
Try parking nose up on a fairly steep incline and letting it idle for a while. This will usually move the air to the radiator where it can be purged.

If you get all of the air out and the system isn't leaking there is no way for it to get back in, but getting it all out can be a pain. Any air in the system always seems to gather in the heater core regardless of the make and model. If you wheel a lot it is possible that you are making the problem worse every time you go down a steep hill because that makes the air try to move to the rear of the cooling system.
08-14-2012 07:44 AM
WXman So did anybody ever find a resolution to this issue? My '12 is doing the same thing. Start the engine and it sounds like a water fountain is running behind my glove box. Should I take it to the dealership or is this "normal"?
06-28-2012 08:52 AM
Lynskey Wow crappy story. I guess Canada has better health care than vehicle care!
06-27-2012 10:42 PM
cooperalp Hi Guys,

After I started complaining about the fact that it is taking to long and there may be something fundamentally wrong with this particular unit, they gave me a rental car. This happened on the 4th day.

The next day, I got a call from the shop manager explaining me that there were several issues with the heating system. The heater core was defective, not letting the water pass through properly. Also, hoses were clogged with junk therefore most needed to be replaced. He told me that they need to order several hoses therefore they need to keep the vehicle longer, till when nobody knew.

The following week, i got several other calls, one from the sales manager and the shop manager, explaining me that these jeeps are made of 35000 parts and every once in a while something like this may happen, they deal with cars like that several times a year, they don't think it is a lemon and once it's fixed, everything will go back to normal, etc...

In the mean time, I called Jeep's customer service, explained them what happened and after a lengthy and frustrating conversation, I was told that there are no lemon laws in Canada, they sold the vehicle to the dealer and I need to deal with the dealer only and there is absolutely nothing they can do about it. They also told me that it is under warranty and they will continue replacing parts until the warranty is over.

The same day, I had a meeting with the sales manager, explained him that manufacturer is not helping and asked if there is any way I can get a replacement. I was told that it rarely happens and I cannot get a replacement unless parts continue failing over and over again. The manager told me that this may take years. I asked him: So unless I blow this thing up, I am not getting a replacement? He giggled and said " Yes". I checked the progress on the car, dash was back in but bunch of pieces were missing from the engine. They were still waiting for parts, it had already been more than 10 working days.

I thought about it over the weekend and decided to get rid of this unit. I contacted the sales manager and asked him what my options are. He told me that i need to pay $2000 if i want to get into the exact same car. I can also step up to a Sahara for another $5000 but that it way over my budget.

I think i will negotiate over the $2000 and try to get into another one as I already lost confidence in this unit. I just want this to be over ASAP, what a nightmare.
Lesson learned for me is not to get a brand new car ever again because the laws are not backing you up. I can sue them and I may get a replacement at the end but I know I will end up spending more to the lawyers so it is not worth it and they are very well aware of that. Bunch of Bozos.

Cheers!
06-13-2012 10:43 PM
JeeperJake my 2008 makes the water sound....

when cold....

Seems like the cure is worse than the complaint. I don't mind a little elemental earth tones now & then.
06-13-2012 10:38 PM
cooperalp I checked the coolant before taking it to the dealer, it was filled up to the brim. I did not test the heater.

72 hours passed, they are still working on the car. So frustrating.
06-13-2012 10:29 AM
Magnum I get this sound too but not all the time, I will be following this thread and looking for the other to see what or IF this is an issue. My heater blows hot too.

I would be nervous about the dealer tearing up my dash as well but they are the "experts" right?.......
06-13-2012 08:54 AM
Lynskey There was another thread about this. I had the same sound when I first got mine. But no leaks and heater air is hot. Now I no longer hear the "water rush" so I assume it was air that finally got purged out.

I recommend you NOT have the stealership rip it apart.
06-13-2012 07:28 AM
chim-chim7 Check the coolant level when cold. You may have a air pocket.
06-13-2012 07:15 AM
RB-10rubicon i hear that all the time in the morning when i start it up and i have a 2010 .thought it was normal .nothing leaks the heater is blazing hot!.once they tare the dash appart who knows how many sqeaks and rattles your gonna get......ill be following this thread good luck
06-12-2012 10:08 PM
cooperalp Hi,

I am new to the Jeeps as well.I noticed the same issue on my 2012 Jeep (3 weeks old). Water rushing noise coming from behind the dash when the engine is cold and it goes away as the engine warms up.

I took it to the dealer the other day, they managed to replicate it and told me that there is an issue with the heater core and they need to change it.

They need to disassemble the whole dash and bunch of other parts around the engine to access it. I don't trust dealers, I hope they don't ruin other stuff as they are trying to fix this issue.
04-24-2012 02:00 PM
ksdindy
Another dumb question - flush of water sound when starting my 12 JKU

Just noticed this, but when I turn on the key it seems as though I hear water rushing somewhere behind the glove compartment. Is this normal and why am I just now starting to hear it?

Thanks for putting up with such a newb!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:30 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC