Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Need Help! Clutch won't disengage.

Join Wrangler Forum Today


Thread: Need Help! Clutch won't disengage. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-29-2012 10:08 PM
Rosky Just got done changing the clutch disk, pressure plate and throwout bearing. The clutch disk and pressure plate were rusted together and that was the problem cleaned the flywheel up and put the new in and runs like a charm! thanks again Jerry
04-29-2012 03:33 PM
Jerry Bransford It doesn't sound like a transmission problem... no guarantees though. While you're in there, you might as well replace the clutch disk and pilot bearing too since you're already planning on replacing the pressure plate. Or if the pilot bearing's needle bearings still feel smooth as mine did, just finger a dab of fresh grease into them.
04-29-2012 03:29 PM
Rosky I held my hand on it as my dad pushed the clutch pedal in and i couldn't hold the rod back so, this might be a stupid question but should i have to worry about it being a tranny problem at all? I'm going to replace the Throwout bearing , clutch fork and pressure plate today to see if that takes care of it.

Thank you much Jerry
04-29-2012 03:22 PM
Jerry Bransford So the rod extends out with enough pressure to work the mechanism inside the bell housing? Have you tried pushing back on on the rod as a helper steps down on the clutch pedal (not petal) to make sure it is extending out with enough force? If so, it sounds like the clutch fork or throwout bearing needs to be replaced... either of which requires you remove the transmission.
04-29-2012 03:10 PM
Rosky
Need Help! Clutch won't disengage.

Well I have an 03 Wrangler with 87k miles and it was sitting for about a month and a half and i go out to drive it , started up fine and the clutch petal has regular movement but the car won't go into any gear and when you try to push the shifter in gear the car will start to inch forward. I can shut the jeep off and the shifter will move into each gear smooth as butter.

I also took the cylinder out that connects into the bell housing to check if the rod extends out and back in and it seems to work just fine. What kind of problem am i looking at here?

Thanks very much.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:13 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC