Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Uconnect for 2007 Problem

Join Wrangler Forum Today


Thread: Uconnect for 2007 Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-18-2012 01:57 PM
xsdbs Well, let us know how it works out for you. I think that the basic features will be working fine, like pairing the phone, placing & receiving calls and playing the iPod thru the docking cable. But I don't think that the streaming audio will work. Which is one of the features on the kit that you bought. Your wife should be happy though and you have something that you can build onto if you wanted.


Quote:
Originally Posted by ZeroAdam View Post
Update. We took the Jeep back in before we left for vacation so they could fix it while we were gone. My wife took the opportunity to use that time to also have them put new 17"s and 35"s on!! Anyway I got the call a few days later and they say that the Uconnect is in and working fine. Exciting news, I'll let you all know once we get back and I get her phone paired.
05-18-2012 09:09 AM
ZeroAdam Update. We took the Jeep back in before we left for vacation so they could fix it while we were gone. My wife took the opportunity to use that time to also have them put new 17"s and 35"s on!! Anyway I got the call a few days later and they say that the Uconnect is in and working fine. Exciting news, I'll let you all know once we get back and I get her phone paired.
05-08-2012 08:15 AM
xsdbs Adding the aftermarket radio shouldn't be any problem.


Quote:
Originally Posted by 949OC View Post
The owners manual in my 2008 says, "this feature not available on Wrangler." Nice After pricing out to add uconnect, I decided I'm going to pay less and install an after market Pioneer with a back up camera. Not getting GPS though because I prefer my portable Garmin. I haven't upgraded yet but I hope I don't have all these issues installing an aftermarket system.
05-07-2012 09:40 AM
949OC The owners manual in my 2008 says, "this feature not available on Wrangler." Nice After pricing out to add uconnect, I decided I'm going to pay less and install an after market Pioneer with a back up camera. Not getting GPS though because I prefer my portable Garmin. I haven't upgraded yet but I hope I don't have all these issues installing an aftermarket system.
05-07-2012 09:25 AM
xsdbs Well a couple of things that you will need to know is that:
1) In 2007, uconnect did not support iPod features, only phone features.
2) The 2007 radio does not have the HW & SW to support streaming audio like your 2012 does.
3) The 2007 radio may be very limited with the iPod capabilities even if they can get it to work. It may play and somewhat have some VR commands but it won't display any information which will make it very difficult to know what you're playing or being able to switch artists, albums, playlist etc. You can use VR commands to say "play artist ******" or play album ****" but you will need to know who and what you have on the iPod.
4) The dealer needs to flash the vehicle with code "RSP" in order for the Uconnect system to operate. This is why when you press the Uconnect button it does nothing. This is done with their scan tool and doesn't need the internet.
5) In reality to make this work to its fullest extent, you will need to replace the radio to a 2011 or 2012 radio. There are people on the forums selling theirs when they have upgraded to a different radio version. (I've seen them for around $100)






Quote:
Originally Posted by ZeroAdam View Post
Thanks steve66!

I spoke with the service manager this morning.

Basically, the program they use to do the programming wasn't able to get the computer to recognize that the Uconnect system is there. So when you press the vr or phone button it just says the usual "Uconnect not available". They also tried to download something via a satellite connection to Chrysler and that was the "internet trouble" that was mentioned earlier. It was also the end of the day saturday and were running out of options before closing.

So the manager said that when they get it back they are going to get chrysler on the phone and work through the issues, he is also going to check and make sure the part is the right part even though the number I came up with is the one that the Mopar site suggests is the one for that year wrangler.

Hopefully things will work out
05-07-2012 07:00 AM
ZeroAdam Thanks steve66!

I spoke with the service manager this morning.

Basically, the program they use to do the programming wasn't able to get the computer to recognize that the Uconnect system is there. So when you press the vr or phone button it just says the usual "Uconnect not available". They also tried to download something via a satellite connection to Chrysler and that was the "internet trouble" that was mentioned earlier. It was also the end of the day saturday and were running out of options before closing.

So the manager said that when they get it back they are going to get chrysler on the phone and work through the issues, he is also going to check and make sure the part is the right part even though the number I came up with is the one that the Mopar site suggests is the one for that year wrangler.

Hopefully things will work out
05-06-2012 07:25 PM
steve66 That sucks bros, hope it gets figured out soon!
05-06-2012 08:09 AM
ZeroAdam
Uconnect for 2007 Problem

So, I'm having a problem. I took my Wife's 2007 JK to the dealer to have the Uconnect system put in. I looked it up on the Mopar site to make sure everything would be fine. This is what I came up with Uconnect Phone, Bluetooth® wireless handsfree, iPod® Integration - 82212159 | Mopar

Clicking the Vehicle Applications link clearly states that it will work in various models of the 2007 Wrangler. I also confirmed that she has the RES model of head unit. The mopar site even lists that with this kit you'll be able to plug in your ipod for music.

After they finally got her Jeep in the back to work on, they call me and say that the unit i picked doesn't provide the ipod integration and that would be another $150 and they can't get until Monday because the parts counter had closed for the day. I told them fine, continue on without, because (like my 2012) she should be able to stream the audio through the bluetooth connection.

A few hours after that, they call me again stating that they've installed the unit but are having trouble programming the PCM, because it's an internet dependent program and they are having internet issues? At this point I stopped listening because I'm mildly angry because not only is this becoming a huge hastle, but it is supposed to be a birthday present for her. So now we have to pick up her jeep, with an installed but non functioning Uconnect system and bring it back to them on Monday so they can spend all day with it trying to get it programmed?

I'm having trouble understanding how this is even possible, that a Mopar part which is listed as compatable for this exact system is not yet working and will not have a usb port either.

I guess i'm just venting. Thanks for letting me

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:16 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC