Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > I need help: YJ bogging/idle-ing/rpm issues

Join Wrangler Forum Today


Thread: I need help: YJ bogging/idle-ing/rpm issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-10-2012 07:48 PM
Tyewilly The fuel pump you bought doesn't have enough pressure for the fuel injection system in your Jeep. The tbi systems require 14-15 psi at the injector. You'll probably want to get a pump that puts put a little more than that so that the fuel pressure regulator in the throttle body can do it's job.
05-10-2012 05:59 PM
Springsblueyj Did you change the fuel filter? It might have gotten clogged.
05-10-2012 05:37 PM
YJDice
I need help: YJ bogging/idle-ing/rpm issues

Let me start by saying I am new to the jeep world, and may not know the correct terminology, but I have no problem getting my hands dirty and fixing what needs to be done.

I own a 1990 YJ Wrangler, 2.5l. I am pretty sure my carb is a TBI. It seems to have all original stock mechanical parts, and ran like a champ. My gas tank had a leak so I needed to fix it. My buddy owned a larger custom gas tank and he claimed specified for jeeps. While changing the gas tanks, we realized that some of the hoses coming from my jeep didn't match that ones on the fuel tank, so we bought larger bulk hoses and connected them with adapters. We re-installed the new tank, not knowing that inside the new tank their was no fuel pump.

We proceeded to turn the key over for 30-35 mins while putting gas into the carb to try and create pressure (as my buddy insisted, along with jumper cables to keep the battery from draining). After a while I was frustrated and said no fuel was running through the lines. I was right because their was no fuel pump inside the new tank.

After taking everything apart again by myself this time is when I realized that their was no pump. So I went to orielly's and the gal their said I needed a fuel pump that had 4-7 psi, and handed one to me for 49 bucks. I installed the new pump as far down the gas line (i made sure this was the right line) as I could and wired it up to my ignition wire. It took 15 mins of turning the key until finally I heard a burp. But it was to late outside in my working environment to continue.

The next morning I turned the key over and it started up, but not the way it should. When it started the rpm's flew to 3k, then way down to .5k, and if I feathered the gas, their is a 2-4 second delay from my foot touching the peddle and a response. I tried to take it down the road, and it keep bogging bad. It died 3 times in 40 yards and would jerk while going down the road as if your slamming down on the brakes. The rpms while fly up and down wildly and dies randomly. I can sometimes maintain a steady 2-2500k rpm in neutral, but that's if i am lucky.


I have reached out for help from all my friends and no one knows. So, I decided to go online to seek some help. This is the first place I ran into, so I signed up and hopefully someone will be able to help me out!!!

Thanks for your time in reading this,
-Austin

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:55 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC