Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > blinkers wipers and radio not working

Join Wrangler Forum Today


Thread: blinkers wipers and radio not working Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-02-2012 03:43 PM
RUBI 4 MY MRS The 3 fuses that power each of those are the only ones that get power from the ignition switch in both the on & acc (back) position. The cig lighter relay is also connected that way. If everything works in acc. position but not in the on position then the ignition switch must have a bad spot & needs replacing.
06-02-2012 10:58 AM
bardb A blown fuse wouldn't intermittently work. Mine has started doing the same and I find jiggling the key will restore power....eventually. I plan to replace the ignition switch once things settle down at home and I actually feel like I have some spare time.
05-30-2012 12:09 PM
Skol-Vikes I would check for blown fusses first.
05-30-2012 11:28 AM
CapeCodRollovers
blinkers wipers and radio not working

i have a 1997 wrangler and my blinkers and wipers won't work as well as the radio. when i turn the key back the radio turns on but when the car is started the radio won't work. could it be the ignition switch???

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:48 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC