Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum > "Check Engine" light

Join Wrangler Forum Today


Thread: "Check Engine" light Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-13-2008 11:58 AM
EUGENE mine was a "electrical stability module/sensor" they had to order mine too.
07-06-2008 07:48 AM
soupy1957 Took the Jeep to the dealer when it happened again....both lights (the ESP light and the Check Engine light).

The ESP light went off after a re-start, but like last time, the Check Engine light stayed on (Constant).

The Dealership indicated it was a sensor (don't remember which one), and they had to order it....should be "in" on Monday or Tuesday.

Seems like my local dealership rarely has "parts" in stock for the 08. I wonder if it is just because it is that new?

Meanwhile, they say I can drive the vehicle without issue, in spite of the idiot lights..

-Soupy1957
07-02-2008 12:13 AM
EUGENE The ESP/BAS light is different than the traction light. I have all three come on and the dealer said it was a malfunctioning sensor. Haven't have the check engine light come on yet...
06-23-2008 10:35 AM
soupy1957 Interestingly enough, the idiot light for the "Traction" (which is what I think it was, but I suppose it could have been the "ESP/BAS" light by proper description), and the "Check Engine" light, stopped showing themselves, and never came back after a couple of re-starts.

I have no idea why they came on, or why they went off, but I'll keep watching and see if they return, and then bring it down to the dealer to read the log on the computer.

-Soupy1957
06-22-2008 09:16 PM
kbart Is it the ESP/BAS light with the little jeep skiding around? this happened to me after a sudden stop the other day. The book said if it didn't go away after several restarts and driving it over 30mph to bring it in to the dealer. It did go away just like they said it would so I won't be bringing it in.
06-22-2008 08:05 AM
yjwrangler yeah ist cause they are a new product line with new stuff. they'll be worth buying in a few years
06-22-2008 07:50 AM
jpdocdave obviously its under warranty like you said. as far as possibilites, they are endless, that light can mean anything. probably something to do w/ traction control, light went on when there was a prob, but went off, but computer stored the code to keep check engine light on.

is it me, or are there a lot of little issues w/ the jk? seems like i hear a lot of warning lights coming on and stuff with low mileage.
06-22-2008 05:57 AM
soupy1957
"Check Engine" light

Had my "Check Engine" light and my "Traction" (?) Light come on in unison yesterday.

The light I'm calling a "Traction" light is for lack of having my handbook handy to properly identify the symbol of the vehicle, with lightning-bolt like marks below each wheel base.

When I shut off the vehicle, and restarted, the "Traction" light (so called) did NOT come back on, but the "Check Engine" light stayed on.

So, I'm not sure if it is something like one of the sensors failing, or if there is a problem with the traction commands or something.

Obviously I'll be bringing it to the dealership to have them look it over, but I was wondering about the typical kinds of issues relative to the "Check Engine" light, that other 08 JK owners are experiencing.

Currently, I have approx. 10,000 miles on the vehicle.

-Soupy1957

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:26 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC