Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Fuse Problem

Join Wrangler Forum Today


Thread: Fuse Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-01-2006 06:58 PM
amerijeep The radio should be connected to accessory so that it goes off with the key, but there is another connection that is to keep the memory set. Something isn't hooked up right.

As far as your lights, there is another thread where I just answered this in the past few days. You surely have a short, and from what you say, you have more than one fuse blow at a time. Correct?? Let me know, and I'll help you out some more.
10-01-2006 06:18 PM
Texapple I'll let the mechanical guys help you with your lighting issues....but I will welcome you to the Wranglerforum family and congratulate you on buying a Jeep
10-01-2006 05:24 PM
timmy43410 Sounds like you have a short in the wiring somewhere. The insulation on the wiring over time gets brittle and breaks. Or it could be that the wiring is rubbing somewhere and now is bare. Its hard to say where it could be but on good way to check for shorts is to pull out all the lights and fuses. Put the fuse in for a certain circuit, say the taillights for instance. start putting the bulbs back in until your fuse pops. Then you will have a good idea of the area of the short.
I had the same prob with a cj-5. I ended up getting a new wiring harness for the back because i had more black tape then wiring when i was done fixing the problems.
09-30-2006 11:19 PM
xxxxxxJetstorm19
Fuse Problem

Hey all. I'm new the Jeep scene so bare with me. In the last week I bought an '87 Wrangler 4.2L. All was fine for the first couple days but all of a sudden its poppin a few fuses on a daily basis. its always the Turn Signals, Brake Lights & Running Lights. Does anyone know what is causing this? Is there some flaw I dont know about? Also today I just had a stereo put in regardless of the fuse popping and for some reason something is making the stereo reset every time i turn off the Jeep. it wont keep any settings like it thinks the battery is being unplugged everytime. Is this tied into the fuses blowing all the time? I need to get this fixed pronto cause if i dont i wont be able to legally get to work without any working rear lights, brakes or turn signals at 6am.

Any help will be greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:00 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC