Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Torn in Tucson

Join Wrangler Forum Today


Thread: Torn in Tucson Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-23-2012 01:25 PM
snochick
Quote:
Originally Posted by GonzoBobH
I had an electrical problem with my 2012. Was a ground issue which the dealer found and corrected. Mine just flashed everything - all dash lights - and then wouldn't start. When it did start, long minutes later, all the dash lights stayed on and none of the gauges worked (e.g. speedometer). As I drove to the dealer it was making a horrible engine whine...

Anyway, it's fixed..

PS In Tucson, too
That happened when we bought our 2011. Dealer said they suspected the people that installed the alarm. We originally bought a 2010 but they couldn't seem to fix it. Mechanic just couldn't figure out where the wiring was wrong. Worked out well for us bc they got a 2011 with all our preferences and color choice for the same price as the 2010. And since we were buying a '10 with '11's on the lot it was a pretty smoking deal on a rubi. Lol
06-23-2012 01:03 PM
GonzoBobH I had an electrical problem with my 2012. Was a ground issue which the dealer found and corrected. Mine just flashed everything - all dash lights - and then wouldn't start. When it did start, long minutes later, all the dash lights stayed on and none of the gauges worked (e.g. speedometer). As I drove to the dealer it was making a horrible engine whine...

Anyway, it's fixed..

PS In Tucson, too
06-23-2012 12:00 PM
snochick I understand. I've got twin 4 year olds that ride around with us in ours. So that would worry me too. I'd definitely take it in to the dealer.
06-23-2012 11:38 AM
KittyPrawn Honestly, the best thing to do is to take it in. The annoying thing about electrical issues is that they aren't always easily reproduceable.
06-23-2012 11:26 AM
UproarinSonoran Of course, you are correct. 3.8L. I guess I saw the identical problem in the NHTSA report and jumped to conclusions. My fault for being so ignorant of my own vehicle. I am new to this whole Jeep experience and should exercise more judicious posts next time.

Any info would be appreciated. We are very hesitant to drive it with our kids in it now.
06-23-2012 05:53 AM
KittyPrawn
Quote:
Originally Posted by snochick View Post
Do you mean 2012? BC 2011 and prior jk was a 3.8. I'm not asking this to be rude. I just own both and I'd like to read up on this.
If he's owned it for over a year, it would have to be a 2011. I'm guessing he has the 3.6 wrong if that's the case.
06-23-2012 03:28 AM
snochick Do you mean 2012? BC 2011 and prior jk was a 3.8. I'm not asking this to be rude. I just own both and I'd like to read up on this.
06-23-2012 01:13 AM
UproarinSonoran
Torn in Tucson

I have owned a 2011 Unlimited 4dr for over a year. I have put 32000+ on it having a freaking blast! BUT I have a huge concern. Today I was braking and making a left turn across traffic into a parking lot and my engine stalled. Steering control, brakes, and obviously acceleration died instantly, placing me and my 3 year old daughter in the path of oncoming cross traffic. I luckily coasted across the lanes and onto the curb of the parking lot.

WHAT IS GOING ON?!! I looked it up and NHTSA has an investigation on 2011 3.6L engines for stalling during braking. WHAT THE HECK???? Why is my Jeep trying to kill me?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC