Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 1999 Wrangler: no rear brakes

Join Wrangler Forum Today


Thread: 1999 Wrangler: no rear brakes Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-24-2008 08:10 PM
Jerry Bransford Better having brake work done by a brake shop, not the dealer that specializes in replacing parts at high cost rather than actually figuring out what the true root cause of your braking problem really is. And rather than go to some nationwide chain of brake shop rip-off artists that have quotas to fill, find a small independent brake shop that belongs to the BBB (Better Business Bureau). They'll figure out what's wrong without ripping you off like the dealer did.
09-24-2008 07:53 PM
4.0l sahara They have auto adjusters but they suck your better doing it yourself.
09-24-2008 04:59 PM
PMorford I have had the same no rear brake problem with my 99 Sport since I bought it. Everything is adjusted and in top shape. I think it is a poor design. I will probably put an adjustable proportioning valve in before the snow falls.
07-02-2007 06:12 PM
Triple88a okay here it is right out of my automotive mechanics book..
Quote:
Automatic brake shoe adjusters normally function when the brakes are applied with the car moving in reverse. If there is too much lining clearance, the brake shoes move outward and rotate with the drum enough to operate the adjusting lever. This lengtens the star wheel assembly. The linings are moved closer to the brake drum, maintaining the correct lining to drum clearance.
07-02-2007 05:18 PM
George T. with my yj, i can just drive in reverse and slam on the brakes jsut short of locking up the tires and thats adjusts them fine.
07-02-2007 05:06 PM
Triple88a 2X.. i agree with ericpl.. wheel star adjuster or whatever you call it seems like a good thing to blame.. drum brakes have springs which make it feel spungy since you step on the brakes.. it uses up the fluid to push the springs out and then the fluid is pressed back by the springs compressing the pistons and forcing all the fluid back into the resvoid..... Dont wranglers have automatic adjusters though?
07-02-2007 07:53 AM
erickpl Did you adjust the star thing at the bottom of the drums? Mine had HUGE amounts of pedal travel before I adjusted them, now they brake REALLY well.
07-01-2007 09:30 PM
Mudweiser If you want to test your rear pads...just pull your ebrake.....its a manual way of engaging just them....if you feel no drag....you either have bad drums or bad pads...or they aint on right. If you have braking with your ebrake then you move onto hydraulic problems. Wheel cyclinders...master cylinder....etc.
07-01-2007 08:04 PM
bubthechub I have a 99 Sahara and its the same way. I think its just a common. If someone knows where to get a good deal on a disc brake conversion please let me know.
02-08-2007 07:54 PM
AzTJ might be the proportioning valve... or worn out springs in the drums.
02-08-2007 06:57 PM
Scottie I have the exact same problem on my 98. Replaced master cylinder, wheel cylinders, and shoes and still didn't work. Took it back to the shop and they put slightly larger pistons in the wheel cylinders which helped a little but still don't work right. They said it was because I had larger tires on (31s). From all of the info that I've gotten on this and other boards, I think the rear drum brakes on the wranglers just don't work well. I'm putting on an 8.8 rear axle with discs in a couple of weeks, so hopefully that helps. Thankfully, this isn't my DD because I won't drive this thing if the roads are slick.
02-08-2007 06:53 PM
Triple88a well spongy is the first sign of air inside the brakes but you say they are bled so thats wird. The first thing i would say is adjust the starscrew or whatever its called. I dont know what else to tell you. For 700$ bucks you could have switched to disk brakes though. From memory some1 sold a kit for like 300$
02-08-2007 06:39 PM
bkaser
1999 Wrangler: no rear brakes

My 1999 Wrangler, 6 Cyl, automatic, ordinary power brakes (no ABS) has virtually no rear braking force. I have only owned it for about 5,000 miles. Since winter hit, I have found that the rear brakes are completely nonfunctional. I cannot lock up the rear wheels even on the most icy roads, even standing on the pedal. That means that the fronts lock up all the time and the rears keep rolling. No malfunction lights, no leaking fluid. On snow, I can hold the car with the front wheels and even at idle the engine will turn one or another of the rears. REALLY DANGEROUS.

The dealer has: Bled everything, replaced the proportioner valve, replaced the master cylinder, replaced a flex hose that links the body and axle portions of the lines, measured the shoes and drums, and put "different springs" on the shoes, though he did not say which springs, or why stronger ones would make the shoes expand better. The Chrysler telephone tech people told the dealer that that is the way the car is, which I don't believe (tech, not the dealer).The pedal feel is the same as always, just a little spongy, which I think must be normal, given all the fluid bleeding that has gone on. The handbrake works normally. I am up to $700 in dealer chargesand I still cannot drive the car on slick roads... And should not drive it at all. I can't understand what is so complicated. Years ago, I drove a Dodge wrecker with power assist, and the brakes were simplicity itself!

Any Ideas from anyone?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC