Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Rio Resurrection: troubleshooting the fuel pump

Join Wrangler Forum Today


Thread: Rio Resurrection: troubleshooting the fuel pump Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-29-2012 12:52 PM
CHRsDad I'm pretty sure that I'll eventually have to drop the tank, if only to clean out whatever has accumulated in there after sitting idle for so long. BUT, since I'm not in any particular hurry, I would like to prove the pump is bad before spending on a replacement. I'm trying to eliminate all the possibilities first.

I really do appreciate any and all suggestions. Bare with me though, I have next to no experience with troubleshooting any vehicle's electric problems.

So, C Beers, could you explain how I would put a jumper on the relay please?

Driller, looking at fuel pump images, I see that connector you're talking about. I'll get to that eventually as I work my way back.

I would still like to find the mysterious fuel system ground that's supposed to be at the emergency brake assembly. Then I can either clean it up or rule it out as the problem.

As I type this, and talk to myself, I'm beginning to think I should drop the tank and put a multimeter on that connector to establish whether or not power is even getting to the fuel pump. Or is there another way?
08-29-2012 07:42 AM
Driller oh yes those wires may go to the switch that turns on dome light for opening the door..Driller
08-29-2012 07:39 AM
Driller could be the connector on the wiring harness at the fuel pump is gunked up or the pins not making good contact. a lot of guys "hard wire "the three wires at that connector to bypass the connector because of repeated issues with it. if you arent getting fuel to fuel rail and filter has been replaced the fuel pump could be bad. dropping the tank isnt impossible but can be a real headache with rusted bolts and getting the fuel pump out is not bad but again rust issues with the in and out metal nipples may make you have to replace the entire pump unit, 150-200.00. if not too much rust put new pump for 60.00.(pump itself not entire unit) I did it this way. check the wiring harness that goes to the tank, hopefully just a cleaning and reconnection is all thats needed. good luck..Driller
08-29-2012 01:39 AM
C Beers Why don't you try and put a jumper on the fuel pump relay.
08-29-2012 12:42 AM
CHRsDad
Rio Resurrection: troubleshooting the fuel pump

It may take 5 years but I'm determined to bring this Rio Grand back to life. A lot has been written on this forum and others about YJ fuel pump issues. Other people's experiences have been helpful as I try to troubleshoot a non-functioning fuel pump.

Here's the situation: It was backed into the garage in '05 and only started a few times since then; not in the last two years. While sitting there something caused the fuel pump to stop working. So now I'm going down the list of things to check before dropping the tank. The engine cranks but doesn't start. CEL comes on for a couple seconds when ignition is switched on. No sound coming from the gas tank. Horn works, but only when ignition is on (is that normal?). No pressure at the fuel rail. Fuel filter is new. Fuel pump fuse is good. Swapped horn and fuel pump relays. Horn still worked, fuel pump did not. I put the relays back the way they were.

Now I'm trying to find the infamous fuel system ground at the emergency brake, but I'm not sure what I'm looking for. So tonight I took a few pictures hoping they might help someone tell me where this ground connection is.

The first picture is looking at the emergency brake peddle and release from the center console. I believe the dangling yellow wire goes to the door light switch. A blue/black striped (?) wire is wrapped with the yellow one. Anybody know what that wire connects to? You can also see an empty connection box just behind the release handle. Anybody know what that's for?

The second picture is looking up the e-brake peddle. You can see the dash fuse block at the top. I'm assuming the white wire in the center of the picture is for the e-brake indicator light. Yes? No?

So where the heck is this ground wire that MIGHT be keeping my fuel pump from working?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:45 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC