Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Need Help! 94 YJ won't pass emissions

Join Wrangler Forum Today


Thread: Need Help! 94 YJ won't pass emissions Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-22-2008 10:45 AM
ChiroSean Thanks. Some people told me to check the O2 sensor, MAP sensor, and MAF sensor. Also they said that changing the engine oil to fresh oil before I take it back for another test might help. I also found a vacuum line up near the passenger side fire wall that I can not find a place where it would go??? My jeep doesn't have AC or cruise control or anything so, not sure where it would go. Any suggestions? Thanks again.
10-21-2008 09:36 PM
jpdocdave that temp is fine, and you probably need a new cat.
10-21-2008 09:02 PM
ChiroSean
Need Help! 94 YJ won't pass emissions

I just bought my first Jeep and can't get it to pas the clean air check here in Indiana. After the first test I changed the plugs, wires, cap and rotor, and repaired the vacuum line between the air box and the PCV. I took it back and had it tested again today and it failed worse than the first time. The hydrocarbons and CO levels are much higher now. I looked at several sites online and there a ton of suggestions, but I thought I would look for some more Jeep specific info if anyone has had similar problems. My Jeep is a 2.5L with a % speed manual trans. Thanks. Also what should the normal operating temp be? Mine runs at or just above 210. Do I need a new thermostat or just flush the cooling system? thanks!!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:11 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC