Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Bad torque converter?

Join Wrangler Forum Today


Thread: Bad torque converter? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-04-2012 04:15 PM
SeVeReDiStOrTiOn Woooohooooooo it was that u-joint!! Man i'm glad to be done with that issue...no more vibs or feeling like i'm dragging an anchor. It must've been binding up something fierce to cause that power loss...glad I caught it in time. Thanks for the suggestions guys.
09-04-2012 12:10 AM
SeVeReDiStOrTiOn I removed the rear driveshaft today for shits and giggles. One of the bearing caps on the u-joint that connects to the diff flange is seized...dunno if this would cause my symptoms or not. Those caps are supposed to spin freely right? I'm going to put a new one in tomorrow hopefully that's what the problem is.
09-03-2012 11:10 AM
jgorm Step one is to drop the pan, change the filter, and do a full fluid flush. TC shudder feels just like driving over cattle crossings. You could have symptoms similar to yours if you are low on fluid, the filter is clogged, the fluid is black, the pump is on its way out, or the TC is on the way out. You can smell the fluid to see if its burnt, but I'd change it either way.
09-02-2012 06:46 PM
Gunner Hope you figure it out and it does not cost you. It sure does sound like a motor mount until you add in the power loss. I am assuming you had someone watch under the hood while you did the power brake thing. The only other thing I can think of would be to look under the chassis for loose bolts in the trans/Transfer case, and dry or tight driveshaft U Joints.
Bob
09-02-2012 04:09 PM
SeVeReDiStOrTiOn oh well I was going to take it in under warranty for the rear main and rear diff pinion seal anyway...maybe i'll get a TC out of it too It just sucks finding time to bring it in.
09-01-2012 02:44 AM
SeVeReDiStOrTiOn
Bad torque converter?

In the last week or so my 05 sport auto developed a shudder/front-end bounce off of idle...almost like you're driving over road strips for a few seconds. There's also a lot of vibration/rumbling sound through the floor pan/gas pedal/seat when accelerating along with power loss. When I let off the throttle and coast everything smoothes out like normal...it's really weird.

I'm thinking it's the TC but I wanna know what you guys think and if this is a common issue. All of these symptoms started at the same time. The motor mounts look good and so do the front/rear driveshaft u-joints. My jeep has 60k on her.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:43 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC