Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Jeep Wrangler Problem- Need Input

Join Wrangler Forum Today


Thread: Jeep Wrangler Problem- Need Input Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-05-2008 07:03 PM
jeep476 when i went to 3rd it fell flat on its face, no acceleration, no power, i kept pumping the gas and it finally picked back up.



this definitly sounds like and o2 sensor but im not a mechanic had a 89 with a 4 banger long time ago and it did something similar to this
11-05-2008 06:35 PM
michael021410 I need help too!!!!! been fighting my 97 w/ 190k on it last 2 months.... within these last 2 months Computer went bad & replaced it, just put all new cat back exhaust, intake manifold gasket, downstream O2 sensor replaced, TPS sensor Replaced...

idles fine on most occasions, will go down road & will die out on me.

I've been most of the work on my own & mechanic has been checking it out & i very much trust him. He did the intake sealing & thought it would fix problem, he doesnt know what to think & said fuel pressure is up to where it should be (7 lbs low i think he said) & suggested new fuel pump. money is kinda tight right now (darn those college loans!)

sadly this is the last place i've stumbled upon & wish it would have been first for opinions!

Thanks in advance & i appreciate the suggestions!
10-26-2008 09:19 PM
Ol' Red Hey man welcome. I doubt it is the fuel line or the exhaust if it only does it in 3rd. Not too sure though. You might want to replace the 02 sensor and see if it fixes it. An 02 sensor will make it run bad but I wouldn't think it would do all of that.
10-26-2008 08:40 PM
cfauver
Jeep Wrangler Problem- Need Input

i just bought a 97 wrangler 4cyl 5 spd 178000 miles. It is in super shape, it just has a small problem. When i bought it the check engine light was on, i had it checked before i bought it, it was the o2 sensor, heater circuit, bank 1. It ran fine with the check engine light on, great power, very responsive, when i had the code reset , i pulled out fine, when i went to 3rd it fell flat on its face, no acceleration, no power, i kept pumping the gas and it finally picked back up. didnt do it again, it did not kick the check engine light again. My wife drove the jeep today, as soon as she started it the check engine light came on. It drove fine, no problems, when she got home i took it to advance auto, checked the code again, same code, o2 sensor. Had it reset ran great till i hit 3rd and it basically shut down again. Kept running though, i went around a sharp turn and then it woke back up. the guy wlmost ran it complelety dry for gas before i got it. some heres my questions, can a o2 sensor make it react like that without kicking the code? could it be trash in the line from the low fuel< i dont think its that or i would do it all of the time. of could it be a catalytic converter being stopped up? it has 40-50 lbs oil pressure, and runs great otherwise. any help would be great, thanks for the forum. chris

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:00 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC