Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > PCM issue? Details and codes inside

Join Wrangler Forum Today


Thread: PCM issue? Details and codes inside Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-27-2006 05:47 AM
4Jeepn Well, if everything was okay before the changes. I would go back and look at the changes. Is the distributer installed correctly, o2 etc etc. Maybe put the old o2 back in and see what you happens. Did you take something else off or is something lose as a result of the things you added. If after all those checks, and it still happens then take to have it looked at.
10-27-2006 12:39 AM
Cole
PCM issue? Details and codes inside

My '97 6 cyl automatic (103k miles) is having some idling problems at highway speed. If I run over ~2000 rpm (60ish MPH) for more than a few minutes it starts missing badly, seems to drop a cylinder or two and naturally the check engine light comes on (been on a while now). If I turn it off and let it sit for an hour or so it runs fine again. After performing the 5x turnkey error code retrieval I get codes 12 (Direct battery input to PCM was disconnected within the last 50 Key-on cycles), 51 (A lean air/fuel mixture has been indicated by an abnormally rich correction factor) and 55 (Completion of fault code display on Check Engine lamp).

I've recently replaced plugs and wires, distributer and button and upper O2 sensor. I'm not sure where to go from here, do I need to consider changing the lower O2 sensor, crankshaft position sensor or is it possibly a PCM problem? Or am I off track and need to seek professional help?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC