Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 92 Fuel pump left me on the road side..

Join Wrangler Forum Today


Thread: 92 Fuel pump left me on the road side.. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-12-2012 07:10 AM
Dr. Venture from what i can gather i believe it says "good work, keep up the maintenance!"
10-11-2012 08:59 AM
jfbilbro
Quote:
Originally Posted by emmaking View Post
vous écrivez vraiment bien, continuer à maintenir

whad he say?......somebody tell me what he said...........
10-04-2012 03:49 PM
Dr. Venture Welded it up, and undercoated amazingly well all over after a fresh coat of primer. Now awaiting my fuel pump assem and i'll finally be done. I also took the time to replace the rear bushings for the chassis to body.
10-04-2012 03:48 PM
Dr. Venture





10-04-2012 03:46 PM
Dr. Venture So the Jeeps still not done. i have to purchase a entire fuel pump assem.
09-27-2012 12:03 PM
Dr. Venture lol,. yes i knew it was going, but pulled a Cramer to see how far i could go..haha!

and the record is 4 months +1 sitting.
09-27-2012 11:23 AM
motormike86 I think we've all been there at least once.
09-27-2012 11:17 AM
denisbaldwin Welcome to Jeep ownership
09-27-2012 11:05 AM
Dr. Venture
92 Fuel pump left me on the road side..

So i come back from a month vacay in Greece and on my way to the GF's my car makes the NJ TP, and part of RT 9 going toward the Amboys. Just about 1/2 mile before my exit Jeep Stumbles and dies.

So i get out and check spark which is good, and just check a few fuses all in tact. I pull off the main Gas line going to motor and used the remote start to check for gas, and sure enough nothing.

I try to kick the rear end tank a little to persuade the pump to kick back into gear but nothing. LUCKY for me jeeps light and i pushed it to the exit and off in front of a house.

Just my luck i get her to the shop drop the tank and the damn beam running right in front of the tank is completely rusted to nothing.

Just more work to be done now. So i ordered the OE replacement from Qtec with some body bushings and am working on her as we speak. I'll throw some pictures up after.

Just wanted to rant a tad!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:10 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC