Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Front freeze plug on a 4.0 engine is white in color

Join Wrangler Forum Today


Thread: Front freeze plug on a 4.0 engine is white in color Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-26-2012 01:12 PM
Old Dogger Thank you, then it must just be a casting indentation.
10-26-2012 10:46 AM
tangofox007 The only sealing plug on a 4.0L engine cylinder head is in the rear, not the front.
10-26-2012 09:47 AM
Old Dogger
Front freeze plug on a 4.0 engine is white in color

I noticed that my front engine freeze plug on my 2003 wrangler is white in color, 48000 miles on the engine. I noticed this when I was cleaning my engine compartment.
The plug does not show any signs of antifreeze leakage.
Is this a sealant that the factory puts on the freeze plug, or is it more likely corrosion starting into a possible problem?
I did have my local Jeep dealer flush and replace the coolant about 3 months ago.
Do you also see this on your 4.0 engines? I had to use a flashlight to see it.
THIS PLUG THAT I AM LOOKING AT IS IN THE CYLINDER HEAD AND NOT THE BLOCK, IT'S JUST ABOVE THE WATER PUMP SO IS IT A FREEZE PLUG OR MAYBE JUST A CASTING FLAW THAT JUST NEEDS TO BE PAINTED BLACK?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:15 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC