Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Cruise Control problems on 2006 Rubicon

Join Wrangler Forum Today


Thread: Cruise Control problems on 2006 Rubicon Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-16-2013 08:56 AM
RLB
Cruise Control

The problem with the Cruise Control was the brake pedal switch, I picked one up and put it on and the cruise works great. I conducted an ohm test on the old one and sure enough, it was bad. Thanks for all the great advice, this is great forum. I found detailed instructions on how to find and replace it, only took fifteen minutes. Thanks Jeep Forum!
11-13-2012 01:46 PM
RUBI 4 MY MRS Mainly check the vacuum line to the reservoir in the fender well under the battery.
11-13-2012 06:23 AM
kylekae At least your Ruby has cruise control haha, but really check the vacuum box where there hoses attach at the nipples, sometimes the hoses somewhat rot and leak there.
11-13-2012 03:55 AM
RLB I will check the vacuum line for leaks. I have not had any issues with the vent switch. It is strange issue, the CC works for 25 minutes or so, then shuts down.
11-12-2012 10:09 PM
blueskiesbill Not sure if this would help you. Mine acted funny twice and without even realizing I I fixed it twice! Basically I realized that it came back to life after disconnecting and reconnecting my battery. Give it a try: it's only wierd if it doesn't work.
11-12-2012 09:57 PM
Some Farkin Guy The CC system is operated via a vacuum line. Check your lines for leaks, might just be a slightly loose boot. I had the same issue in my 2005. Does yours by chance have any issues with the vent switch? Mine had a tendency to stay on defrost until I found the leak because it's on the same vacuum line as the CC.
11-12-2012 08:55 PM
RLB
Cruise Control problems on 2006 Rubicon

My 2006 Rubicon has a cruise control problem. The CC works for about 20 to 25 miles then the green cruise light goes out and the CC stops working. After I stop for a few minutes, it will work fine for another 25 miles or so. Any help appreciated!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:53 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC