Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Speedo went crazy...

Join Wrangler Forum Today


Thread: Speedo went crazy... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-31-2008 04:41 PM
distortedtj
Quote:
Originally Posted by ajohnson928 View Post
oh and the shift light is coming on even in 5th gear.
Even though the arrow points up, It also tries to work as a downshift light also. It's the computer wanting to keep within a certain RPM for "jeeps" so called maximun fuel saving range.
12-31-2008 04:36 PM
distortedtj To piggyback on Jerry. To pull the speedo gear out just take the bolt with the retaining clip off to remove the speedo assembly. The speedo gear will be attached to it and will come out with the assembly. Inspect it closely for any damaged or missing teeth.
12-31-2008 04:19 PM
Jerry Bransford What do you mean the connector was replaced with the VSS? If you still have a speedometer gear, which you would unless you have a super-short JB SYE kit installed, it's probably just not fully engaging the pinion gear inside. To cure that, you need to rotate the speedometer gear housing a tad to get it to fully engage again. But if its been doing it long, the plastic speedometer gear teeth may be worn so it may need replacing.
12-31-2008 04:09 PM
ajohnson928 oh and the shift light is coming on even in 5th gear.
12-31-2008 04:08 PM
ajohnson928 I just ran out and checked it. It's tight.

The connector was replaced with the VSS.

Any other suggestions?
12-31-2008 04:03 PM
distortedtj
12-31-2008 04:02 PM
distortedtj Your shift light works off of RPM's

Look at the backside of the transfer case. Where your speedo gear is located. Check the electric connector going to it.
12-31-2008 03:56 PM
ajohnson928
Speedo went crazy...

I've got a 97 TJ 2.5L 5spd with 112K on it.

The other morning while I was driving about 45mph the speedometer started jumping up to 55-60 then dropping down to 30-35. When I got home I parked her and let her sit most of the day. That night I drove it again and there was no problem for several hours then it began again. Eventually it was dropping lower and lower (saying I was going 35 on the interstate when I was doing 65-70). Eventually it just stopped working all together.

Later the Check Engine light came on. Pulled to code (0500 malfunctioning speed sensor) and then changed the VSS. Cleared the code but nothing happened with the speedo with the new VSS. The odometer is not clicking miles over but the shift light has worked all along.

I pulled to cluster and checked all the connections. No change after that. I'm stumped ... anyone else know what's going on?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC