Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 3rd rear main seal???

Join Wrangler Forum Today


Thread: 3rd rear main seal??? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-06-2009 05:07 PM
jeepjeep less pleasent... same for sure... my truck is back at the dealer right now, they replaced the release bearing last week (mon thru wednesday) I picked it up after hours since they closed early new years eve. well when i picked it up that night as soon as i started it the trans was really banging around loud!! So then I looked around under it and found a sheared off bolt(from tranny mount to skid plate). My 4wd light does not come on now(which the left the sensor unpluged), it locks in 4lo, and the new release bearing squeaks when hot!!!WTF?so i called them on friday , they said to bring it in monday. I dropped it off sunday night, got no call on monday or tuesday, so i call them, they told me they were replacing the mount but my clutch is bad making the banging sound?? It never did it before they dropped the trans to replace the first release bearing, i am going to give them until tomorrow to do the right thing if they dont then i guess i will be contacting chrysler...t.b.c.
01-06-2009 01:53 PM
jp'rs_peep'rs WOW! WOW! WOW!
Now that is a dealer worth going too!

Man if only we had dealers here in SE WI who behaved that way...The ones here in my home town have been well less then pleasant.

LOL!
01-06-2009 01:06 AM
Joe Dirt I have an 03 and had a similar issue. Fortunetly I had an honest dealer who looked deeper. He told me my engine had been assembled in a faulty manor. The crankshaft was loose. They replaced the entire engine free.
01-05-2009 09:00 PM
orange05tj Rear seal changed at 19k then again at 26k, and its leaking again at 47k. They put some dye crap in it and then told me my warranty was expired after they changed the power steering pump, tensioner and belt at 38k miles. I have the 6 speed, havent had any probs with it....yet.
01-05-2009 08:55 PM
jeepjeep
3rd rear main seal???

So i picked up my truck from the dealer with the 3rd rear seal installed. mine keeps leaking ,anybody else? If it happens one more time then i am going to raise some hell w/ chrysler(not that will actually do anything!!).It has to be either a scarred crank flange or installed incorrectly.

And on another rant who where has a six-speed trans, does it grind sometimes going into 2 or 3?just curious...

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:17 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC