Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Spartan Locker HELP

Join Wrangler Forum Today


Thread: Spartan Locker HELP Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-21-2012 08:15 PM
TripleNickle UPDATE: There was a thrust washer installed on the passenger side, and what do you know the bearing was ate up too! Thanks for all the feed back.
12-21-2012 04:51 PM
TripleNickle Its in the front, just a typo on my behalf.
12-20-2012 10:04 PM
_KONG_
Quote:
Originally Posted by TripleNickle View Post
Thanks for the feed back, im going to have them pull the rear cover off and get the center gap measurement. Can you visually see the thrust washers if they are infact still in there?
I thought you installed it in the front. Why pull the rear cover? If you put the locker in the rear it will act a whole lot different than in the front
12-20-2012 07:34 PM
TripleNickle I have the cross shaft and 1 washer, they are going to check it out, but the parts where in the recycle when I asked for them back. So its possible they didnt find the 2nd washer or its in there.
12-20-2012 04:42 PM
scot68
Quote:
Originally Posted by TripleNickle View Post
Thanks for the feed back, im going to have them pull the rear cover off and get the center gap measurement. Can you visually see the thrust washers if they are infact still in there?
No unfortunately they are not visible without removing the drivers & couplers. They will basically have to remove the locker to inspect.
You could ask the shop to produce your old washers and cross shaft, if they can't they are probably still in the diff.
12-20-2012 01:32 PM
TripleNickle Thanks for the feed back, im going to have them pull the rear cover off and get the center gap measurement. Can you visually see the thrust washers if they are infact still in there?
12-20-2012 11:52 AM
scot68 As mentioned above if the original thrust washers were reinstalled this could cause the condition you described. Spartan is the only lunchbox locker I am aware of that does not reuse the thrust washers. After install is complete a measurement must be taken (gap between the drivers) it should measure between .145" -.170".. This measurement will be off if the washers were reinstalled causing increased spring pressure on the drivers. Also make sure the shop installed the hardened cross shaft provided with the kit instead of your original shaft.
12-20-2012 12:37 AM
_KONG_ Its not hard to get in there and check for yourself. But if you already paid someone to do the work then let them deal with it
12-19-2012 11:01 PM
TripleNickle Ive spent the last 2 hours researching, and I think thats the issue. They left the thrust washer in. It only really locks on the left wheel. So mad it makes it difficult to turn. I should have not been in a hurry to get it done and waited until I had time to do it my self.
12-19-2012 10:49 PM
_KONG_ It is more noticible when you first install it but should not be locking up like you say. I noticed mine liked to do it on slow left turns or u turns. I would make sure the shop left out the thrush washers. Theres a gap between the locker halves that needs to be in spec to work properly
12-19-2012 09:30 PM
TripleNickle Idk like i said i had a shop install it and i gave them the instructions lol. This thing is bad, u def can tell its there like driving in 4wd.
12-19-2012 09:21 PM
Tdog02 Spartan instructions say to remove the thrust washers. Was this done? I am an amateur and did mine 0.0 problems. Other possibilities, check that first.
12-19-2012 07:59 PM
TripleNickle
Spartan Locker HELP

I just had my spartan locker installed in my D30. My question is: Should it be locking up really hard when in 2wd. I mean it feels like its in 4wd. Also when driving I can feel it pulling hard to the right, and when i turn right while coasting it grabs harder then if I am going to the left. Is this normal, or did the shop some how mess something up. It seems pretty straight forward. Everyone told me before it would click, but its locking up hard. As to the point where it SUCKS to drive. Please help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:00 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC