Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > KC light install problem

Join Wrangler Forum Today


Thread: KC light install problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-02-2013 04:53 PM
joey4821 I want to thank everyone for all the help. I just got off the phone with the guy from customer support at KC lights and he told me to take the ground wire and put it on the negative side of the battery. And now it works. . . Go figure. Now off to try them out and aim them.
12-31-2012 11:11 AM
Jerry Bransford Your relay isn't clicking (energizing), at least you can't hear it clicking. The relay is a very basic circuit, it's not as difficult as some think it is... so it's not hard to get working if you take some very basic steps.

There are four main connections on a relay when used for driving lights... two of those energize it, the other two are simply the on-off contacts that turn something on... like your driving lights.

Pins 85 and 86 on the relay are the two leads that when power is applied to them, energize the relay. If those two pins get 12v, the relay will energize. All those two connectors need to energize the relay is a ground and +12v. It doesn't matter which of those two gets ground or the +12, they are not polarity sensitive. If you connect a ground to one of them and +12 to the other, the relay will energize.

Find out which is missing on those two pins, ground or +12v, and you'll find out why the relay is not turning on. Incidentally, those PIN numbers like 85 and 86 are molded onto the bottom of the relay next to connections themselves. Pins 30 and 87 are the on-off connections for the lights.
12-31-2012 09:53 AM
joey4821 No I have not wired them to be turned on with my headlights. they are wired separately. They are wired almost exactly like the second image Jerry posted. http://support.kchilites.com/index.p...h&attach_id=20

this is the image given to me with the instructions.
12-31-2012 07:52 AM
Steve305
Quote:
Originally Posted by Wesboy View Post
Have you wired them up so you need your headlights/high beam on for the KCs to work?
THIS ^^^^^ question needs to be answered.
12-31-2012 05:59 AM
jp2611 I am assuming here.....and this may or may not be correct.....and is not KC light related exactly.
You said you don't do much electrical..hence no test light. You are going to pick up a multimeter while inexpensive is more than a simple test light. Which also means it does more....but when it is not working COULD throw you off...also requires batteries in most that I have seen. If you are not real familiar with electrical a "iffy" multimeter could cause you problems while you try and diagnose an issue, say you pull it back out of the bottom of the tool box down the road and think everything is "fine" with it. And in reality it is not working due to poor batteries, or broken wires or something got loose came loose from rattling around in the bottom of the tool box.

A multimeter is great to have if you have the know how and are checking sensors for values/ and known needed values at certain times when certain conditions are met. If that is something you see your self doing than a multimeter is the way to go.

If it is mostly testing lights.....

My suggestion:

Get the mentioned test light.

Get a couple/ 4 small "alligator clips" than can be attached to the end of a piece of wire.

Get 2 small coils of wire...one red one black.

Make a couple about 6 foot jumpers. Save the extra wire for "just in case" some day you will need it.

The test light is very basic and if there is ever a question..you can use the jumpers from the battery to test any light issue and 6 foot will just about reach it anywhere on the Jeep.

Total cost will be about $10 but if all you are ever going to do is lights, you will be pretty well set. ('cept for wire-pliers/ cutters and some end terminal connectors)
12-30-2012 10:48 PM
Motowithy As above member said. I have the same lights and I know they tell you to piggyback off the headlights so it might be you wired properly and just have to put the headlights on and then try the switch.
12-30-2012 09:52 PM
Wesboy Have you wired them up so you need your headlights/high beam on for the KCs to work?
12-30-2012 09:22 PM
joey4821 So I just had someone turn the switch in my dash on and off while I listened by the relay and I heard nothing. . .

Looks like I'll make a trip down the street to harbor freight tomorrow for a multimeter, but in the mean time checking for the audible click was the only thing I could do tonight.
12-30-2012 08:20 PM
monkeee2002 get yourself a tester light. They're too cheap to not have one.
Check for power at the fuse - upstream & downstream of the fuse. Also, double check your ground wires (if both lights are failing to power up, then it's probably not the ground, but it never hurts to check). Try running a spare length of wire from the light's ground to the battery negative terminal, or a similar "guaranteed-good" ground location.
12-30-2012 08:02 PM
Jerry Bransford Put your ear next to the relay as someone flips the KC light switch on-off with your Jeep parked in a quiet location. Does the relay make a soft audible click as the KC switch is turned on & off?

Think of that relay as a remote control switch for the lights. The relay is what turns the lights on/off, with the cockpit switch what turns the relay on/off.

Telling us if that relay is energizing or not will help us to diagnose the problem.

Here are two good wiring diagrams that may help you to understand how it all works so you can figure out what is wrong. The "high current load" in the first animated schematic are the two driving lights, click on it to start its animation.
12-30-2012 07:52 PM
Dextreme A $5 multimeter from Harbor Freight is great for troubleshooting and tracing the problem....takes the guess work out. I had a KC light bulb go out a few days ago and I was able to measure that the two wires were getting 12v to the bulb, so I new the bulb was shot.
12-30-2012 07:49 PM
MosesTJ I would double check your ground if you do not have a tester. You can get one from advanced for a couple bucks.
12-30-2012 06:30 PM
joey4821 na I don't do much electrical work so I never bought a test light.
12-30-2012 06:20 PM
jp2611 Have a test light?
I would check at the plug/ junction where the lights plug in at the housing and ensure that I have hot AND ground at that point......if not trace back and see at what point it doesn't work.....
12-30-2012 06:18 PM
B-wils-TJ I had the same problem with my in line fuses. One of the didn't have a good connection. You could try wiggling the fuses with the switch on to see if that works
12-30-2012 06:15 PM
joey4821 No I've pulled the fuses out and they look fine.
12-30-2012 06:05 PM
tallzdatank are the fuses blown?
12-30-2012 06:03 PM
joey4821
KC light install problem

So I just rigged up some KC 100watt 6" windshield mounted lights and they will not come on. The wiring is properly run (I checked it 10 times). However I noticed after I finished that the instructions say to take the fuses out before wiring up the lights then replace the two fuses just before hooking everything up to the battery. I had the fuses in the whole time I was installing and wiring them up. Could this be the reason they are not turning on? I can't figure it out. This is the link to the exact lights I purchased KC HiLiTES 100 Watt Daylighter Pair Pack System, Black 6" Round KCH-238

Does anyone have any suggestions? Very frustrated...

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:49 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC