Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Engine rich and possibly out of time!!!!!

Join Wrangler Forum Today


Thread: Engine rich and possibly out of time!!!!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-07-2009 05:18 PM
K.T. Try car-part.com for a used one in your area to save some cheddar. It is a pretty cool used part website you can search by region and it gives you phone numbers. Just check it out if your interested.
02-07-2009 08:59 AM
Jb1234 I have figured out it is the Computer...And it is Throttle Body Injection...The computer is not working in the cold...If I take a hairdryer and warm the computer...It starts....So I have looked for a computer...But cant find one...Is it important to have the model code...mines 56028 then in bold 828...I cant find one exactly like that...Autozone says they have a computer but with 829...Should I purchase
02-06-2009 12:42 AM
flattietj if u r too proud or to far away just flash it and then call in the code
02-05-2009 08:06 PM
K.T. I would scan it on some type of computerized diagnostic tool. They'll do a scan at most chain auto parts stores for free around here. That will give you a better place to start than replacing everything that is part of your fuel delivery system.
02-05-2009 04:42 PM
jpdocdave 95 is multi port. and make sure the distributor is right before doing anything.
02-05-2009 04:02 PM
whitebuffalo is the 95 tbi or mpi? if its tbi, theres only the one injector. iirc, when the regulator went, it would run even if i unplugged the fuel injector.

i guess its possible the injector is hanging open pouring in fuel....but ive never seen it 1st hand.

is it hard to start?
02-05-2009 03:42 PM
Jb1234 I have replaced the Fuel pump, Fuel pressure regulator, fuel filter and the only thing i can think of is the fuel injectors...
02-05-2009 11:55 AM
whitebuffalo sounds like what mine did when the fuel pressure regulator went kaput. on mine, i could look down the throttle body and see gas pouring in.
02-05-2009 09:45 AM
Jb1234
Engine rich and possibly out of time!!!!!

My vehicle will start then shut off...Heavy smell of gas...TONS of Carbon shoots out of the tailpipe...BACKFIRES...And this only happens when cold...Will also shut off while driving...(I think thats because there is not enough oxygen to burn all of the fuel...)Could it be the fuel injectors? What do these symptons usually mean...I feel the backfire is because of the distributor is out of time...Also the RPM's are very low when braking...Almost and sometimes to the point of shutting off...ANY SUGGESTIONS ARE HELPFUL....


By the way I have a 95 Jeep Wrangler 4 Cyl. TBI

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:48 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC