Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Snapping/popping noise

Join Wrangler Forum Today


Thread: Snapping/popping noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-17-2013 06:39 PM
EMTJEEP
Quote:
Originally Posted by ALjeep View Post
You didn't say if your Jeep if lifted or not. I've been noticing the same with mine. I have a pop when I back out of garage and occasionally at other times so I was thinking maybe I have some loose bolts in suspension. Got under there this afternoon and tried tightening several bolts. Only found one questionable on one of the frame to tub bolts. Everything else seemed tight. Maybe its just something to live with on a lifted Jeep.

It is a lifted but I have never had this problem and until recently. And everything it snug and has not budged. Every bolt I tighten I mark them, so I can see if they move. I don't think its suspenion related because it happens on the freeway going 50-70mph when I have to let off the gas fast and it almost seems like the drivetrain is trying to catch up.
02-17-2013 05:18 PM
jp2611
Quote:
Originally Posted by ALjeep View Post
You didn't say if your Jeep if lifted or not. I've been noticing the same with mine. I have a pop when I back out of garage and occasionally at other times so I was thinking maybe I have some loose bolts in suspension. Got under there this afternoon and tried tightening several bolts. Only found one questionable on one of the frame to tub bolts. Everything else seemed tight. Maybe its just something to live with on a lifted Jeep.
Mine is lifted and SL has been for over 2 years...BL was done 6 months ago.

I have no "funny noises" I am a little anal like that, if there is a noise of something "loose" I tighten it up or replace it....one time was u-joint one time was upper rear shock mount broke other was still there...IMO if you hear noises something not right.
02-17-2013 05:12 PM
ALjeep You didn't say if your Jeep if lifted or not. I've been noticing the same with mine. I have a pop when I back out of garage and occasionally at other times so I was thinking maybe I have some loose bolts in suspension. Got under there this afternoon and tried tightening several bolts. Only found one questionable on one of the frame to tub bolts. Everything else seemed tight. Maybe its just something to live with on a lifted Jeep.
02-16-2013 09:13 PM
C.L.
Quote:
Originally Posted by apbadger View Post
An easy way to check if it is your front drive shaft is to unbolt it from your front axle and tie it up to the frame. If the noise is gone you know the problem is the u joints.
If you hear a horrible grinding thrashing sound followed by pieces of drivetrain spewing out all over the road, it was left in 4wd.
02-16-2013 09:05 PM
EMTJEEP
Quote:
Originally Posted by apbadger View Post
It sounds like it could be the front drive shaft normally refereed to as angry sparrows. An easy way to check if it is your front drive shaft is to unbolt it from your front axle and tie it up to the frame. If the noise is gone you know the problem is the u joints.
Front driveshaft was rebuilt along with the rear, but it's not installed so the whole front is not in question. There is no play in the rear drive shaft at all. The noise is not constant and only happens for a second. It's starting to sound like something is binding though so it could be the CV going out. The shaft is still under warranty.
02-16-2013 08:48 PM
UFOtestpilot I think I've been hunting a similar issue but mine only happens on take off and only up to about 10-15 mph. Just a few "rattle-clacks". I'm down to thinking it's the front drive shaft ujoints so I'll be verifying that and replacing them next weekend probably.
02-16-2013 07:52 PM
jp2611 I was just thinking u-joints but can't tell you which one...and even though just rebuilt....IMO that is no proof one of them can not be bad......
02-16-2013 07:41 PM
WranglerWarrior
Snapping/popping noise

Quote:
Originally Posted by apbadger View Post
It sounds like it could be the front drive shaft normally refereed to as angry sparrows. An easy way to check if it is your front drive shaft is to unbolt it from your front axle and tie it up to the frame. If the noise is gone you know the problem is the u joints.
Was thinking the same
02-16-2013 07:23 PM
apbadger It sounds like it could be the front drive shaft normally refereed to as angry sparrows. An easy way to check if it is your front drive shaft is to unbolt it from your front axle and tie it up to the frame. If the noise is gone you know the problem is the u joints.
02-16-2013 06:44 PM
EMTJEEP
Quote:
Originally Posted by Philmycrackin View Post
I have no usefull info for you but, the first thing that came to mind was a mouse eating rice crispies in your back seat. Snap,crackle,pop and the mouse squeaking

Sorry for my lack of help
Yeah I was going to make the title Snack, Crackle and Pop.
02-16-2013 06:36 PM
Philmycrackin I have no usefull info for you but, the first thing that came to mind was a mouse eating rice crispies in your back seat. Snap,crackle,pop and the mouse squeaking

Sorry for my lack of help
02-16-2013 05:43 PM
EMTJEEP
Snapping/popping noise

I got a popping noise that happens when my jeep sits for a little and when i go from take-off back or forwards there a popping kind of noise. But once it does the first time it doesn't do it anymore or barely 1-2 more times. Also when driving mainly in 1-3 gears and I let go of the gas pedal it makes a high squeak chirp/snapping noise. Or when on the freeway in gears 4-5.

I just had the rear drive shaft completely rebuilt by a very reputable place. So I don't think it is my CV making the noise but will check it out when I get a chance. The control arms were replaced not too long ago.

Any help would be great!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:54 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC