Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Needed thoughts.

Join Wrangler Forum Today


Thread: Needed thoughts. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-18-2013 11:45 AM
Jerry Bransford
Quote:
Originally Posted by OCsmelly View Post
Thanks for the advise. Pulled the throttle body and it was petty gummed up cleaned it up and now she is running magnificently.
To keep it clean, I'd replace that new K&N with a good quality paper element air filter like from AC-Delco. K&N's air filters are about as good at filtering fine dust, silica, etc. out of the engine as a screen door is at keeping the dust from a Texas dust storm out. K&N's air filter really are very poor at filtering the air, really. I ran a K&N for a year or two before I figured out just how much dirt & dust it was passing. I went back to a paper element air filter & besides noticing no change in engine performance, I soon noticed the air intake was staying clean again. Lab tests ranked the K&N at the bottom so far as its ability to filter dirt & dust.
02-18-2013 11:24 AM
OCsmelly
Quote:
Originally Posted by Dextreme View Post
My first reaction would be to pull the throttle body off and clean it as well the IAC sensor really well with Throttle body spray. Also make sure its not something simple like a super dirty air filter.
Thanks for the advise. Pulled the throttle body and it was petty gummed up cleaned it up and now she is running magnificently.
02-01-2013 04:45 PM
OCsmelly Thanks will give it a whirl . I am pretty sure the air filter is good put a k&n on when I bought it a month ago. If any other thoughts come please throw it out there. Will be under the hood most the day tomorrow so won't mind checking more things out.
02-01-2013 03:11 PM
Dextreme My first reaction would be to pull the throttle body off and clean it as well the IAC sensor really well with Throttle body spray. Also make sure its not something simple like a super dirty air filter.
02-01-2013 03:02 PM
OCsmelly
Needed thoughts.

I have an 05 with 70,000and just got the transmission rebuilt and a new clutch. Than took a 800 mile road trip and when I got back it is now almost stalling when I am coming to a stop. Going to do plugs and stuff tomorrow. My question is should I mess with the idle? There was about 150 miles of offroad in my trip as well.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:39 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC