Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Failed HVAC fan part 3. The saga continues...

Join Wrangler Forum Today


Thread: Failed HVAC fan part 3. The saga continues... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-18-2013 01:50 PM
Vicvector
Failed HVAC fan part 3. The saga continues...

OK, I found the fan resistor pack and when I removed it, it was filled with furry debris (think clothes dryer filter). Removed the first clump and the fan came on. I blew out the rest of the junk and reinstalled the pack. OK great right ? An hour later, the fan was dead again. I took the pack out again and noticed that one end of the connector was melted. The connector still unplugs.

I want to use my ohm meter to check the pack. Does anyone know what the readings between the pins should be ? Also, the connector is garbage and I'm thinking of soldering the wires directly on the pack pins or using crimp push on terminals to connect the pack. Seems like a bad situation for a connector and wire insulation to melt.

Thanks in advance for any help. Jim (98 TJ Sport)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:35 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC